Bug 1225926 - Overcloud deployment fails when provisioning Ceph node
Summary: Overcloud deployment fails when provisioning Ceph node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: Director
Assignee: Mike Burns
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-28 13:15 UTC by Marius Cornea
Modified: 2015-08-05 13:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:52:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
ceph deployment (27.77 KB, text/plain)
2015-05-28 13:15 UTC, Marius Cornea
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Marius Cornea 2015-05-28 13:15:50 UTC
Created attachment 1031280 [details]
ceph deployment

Description of problem:
Overcloud deployment fails when provisioning a Ceph node.

Version-Release number of selected component (if applicable):
openstack-tripleo-0.0.5-999.el7ost.noarch
openstack-tripleo-common-0.0.0.post4-1.el7ost.noarch
openstack-tripleo-image-elements-0.9.3-1.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.1.dev55-1.el7ost.noarch
openstack-tripleo-heat-templates-0.8.4-2.el7ost.noarch
instack-0.0.6-5.el7ost.noarch
instack-undercloud-2.1.0-3.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Set up 3 nodes virtual environment according to the docs
2. Install undercloud
3. Build images
4. Register nodes
5. Discover nodes
6. export CEPHSTORAGESCALE=1
7. export CINDER_ISCSI=1
8. instack-deploy-overcloud --tuskar

Actual results:
Overcloud deployment fails.

Expected results:
Overcloud deployment succeeds.

Additional info:
I am attaching logs and deployment details.

Comment 3 Marius Cornea 2015-05-28 14:12:28 UTC
Ceph doesn't seem to get installed:

[heat-admin@ov-35hwusknazj-0-nmhw5ozqijxa-controller-5mkjux6vevml ~]$ rpm -qa|grep ceph
[heat-admin@ov-35hwusknazj-0-nmhw5ozqijxa-controller-5mkjux6vevml ~]$

Comment 6 Mike Burns 2015-06-18 09:51:32 UTC
The issue here is that ceph components were not on the overcloud image.  This is resolved.

Comment 9 errata-xmlrpc 2015-08-05 13:52:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.