Bug 122593 - Under SELinux and kdm, "Exit -> Reboot" only exits, but does not reboot.
Summary: Under SELinux and kdm, "Exit -> Reboot" only exits, but does not reboot.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: SELinux
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-06 04:22 UTC by Aleksey Nogin
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-26 23:25:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2004-05-06 04:22:45 UTC
If I am running kdm and I choose the reboot option in the KDE exit
menu, my KDE session is shut down properly, but the machine does not
reboot.

In the logs, I see:

audit(1083816206.762:0): avc:  denied  { write } for  pid=2764
exe=/usr/bin/kdeinit name=xdmctl-:0 dev=hda2 ino=1144796
scontext=aleksey:staff_r:staff_t
tcontext=system_u:object_r:xdm_var_run_t tclass=fifo_file

IMHO this should be fixed by either relocating the xdmctl into
/tmp/.X11-unix, or explicitly making sure it has the same type as
/tmp/.X11-unix/X0 (currently - xdm_xserver_tmp_t) which users are
allowed to write to.

kdebase-3.2.2-4 policy-sources-1.11.2-21

Comment 1 Ngo Than 2004-09-26 23:25:23 UTC
i cannot reproduce it with KDE-3.3.x in rawhide. it's fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.