Bug 122595 - USB devices such as flash disks and scanner not recognized a boot time
USB devices such as flash disks and scanner not recognized a boot time
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 01:06 EDT by Brian G. Anderson
Modified: 2014-03-16 22:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 16:52:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Very simple workaround for scanners (286 bytes, patch)
2004-07-10 18:09 EDT, Rodrigo Damazio
no flags Details | Diff

  None (edit)
Description Brian G. Anderson 2004-05-06 01:06:37 EDT
Description of problem:
When I boot my system with a scanner and/or a flash disk, they are not
recognized at boot time.  I always have to unplug the devices and
replug them in after boot.


Version-Release number of selected component (if applicable):
usbutils-0.11-4


How reproducible:
always


Steps to Reproduce:
1. plug in a scanner and or flash disk befor boot
2. boot the system
3.
  
Actual results:
Neither device is present at boot.  Only after unplugging the devices
and replugging them in are they recognized


Expected results:
the devices should have been recognized at boot.


Additional info:
Comment 1 Rodrigo Damazio 2004-07-10 18:09:33 EDT
Created attachment 101781 [details]
Very simple workaround for scanners

We should also be changing the X session startup scripts somewhere to give
console owner permission when a user logs in, but I'm not sure where that's
done.

You can also use Debian-like permissions by creating a "scanner" group and
changing the chomd for a chgrp to that group.
Comment 2 Rodrigo Damazio 2004-07-10 18:10:15 EDT
Oops, forgot to mention - that patch is for /etc/hotplug/usb/libusbscanner
Comment 3 Orion Poplawski 2004-12-13 13:08:58 EST
Seeing this with a USB cd-rom device.  At boot I see:

Dec 13 10:47:01 lynx kernel: uhci_hcd 0000:00:1d.2: UHCI Host Controller
Dec 13 10:47:01 lynx kernel: SCSI subsystem initialized
Dec 13 10:47:01 lynx kernel: Initializing USB Mass Storage driver...
Dec 13 10:47:01 lynx kernel: scsi0 : SCSI emulation for USB Mass Storage devices
Dec 13 10:47:01 lynx kernel: uhci_hcd 0000:00:1d.2: irq 11, io base 00001860
Dec 13 10:47:01 lynx kernel: uhci_hcd 0000:00:1d.2: new USB bus registered,
assigned bus
number 4
Dec 13 10:47:01 lynx kernel:   Vendor: SAMSUNG   Model: CD-ROM SN-124     Rev: N102
Dec 13 10:47:01 lynx kernel:   Type:   CD-ROM                             ANSI
SCSI revis
ion: 02
Dec 13 10:47:01 lynx kernel: usbcore: registered new driver usb-storage
Dec 13 10:47:01 lynx kernel: USB Mass Storage support registered.

so it sees it.  Then a bit farther in the logs:

Dec 13 10:47:01 lynx kernel: usbcore: deregistering driver usb-storage

Have to remove and reattatch the drive to get the system to see it.
Comment 4 Orion Poplawski 2004-12-13 13:13:48 EST
Should note that this is with FC3.
Comment 5 Bill Nottingham 2005-09-30 16:52:15 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Please try to reproduce this on a current release, such as Fedora Core 4. If the
issue persists, please open a new issue. Orion - your issue sounds like a kernel
bug.
Comment 6 Orion Poplawski 2005-09-30 18:02:53 EDT
Looks like the USB CD-ROM issue is fixed in FC4.

Note You need to log in before you can comment on or make changes to this bug.