Bug 122598 - Anaconda creates suboptimal RAID5 configurations
Anaconda creates suboptimal RAID5 configurations
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
FC3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 02:04 EDT by H. Peter Anvin
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 12:14:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H. Peter Anvin 2004-05-06 02:04:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b)
Gecko/20040105

Description of problem:
Anaconda/Disk Druid creates RAID-5's with algoritm = 0
(left-assymetric.)  However, the recommended algorithm for general use
is algorithm 2 (left-symmetric.)

Unfortunately, there is no easy way to recover this after system
installation, so this is a major flaw.

Version-Release number of selected component (if applicable):
FC2test3 CD ISOs

How reproducible:
Always

Steps to Reproduce:
1. Create a RAID-5 with Disk Druid.
2. Look at /proc/mdstat.
3. Read the md documentation.
    

Additional info:
Comment 1 Jeremy Katz 2004-05-06 15:00:51 EDT
anaconda has never set this explicitly and instead just goes with the
defaults for the raid tools/kernel.  At this point, it's too late to
change for FC2 (it wouldn't get any testing at all), so targeting for FC3.
Comment 2 H. Peter Anvin 2004-05-08 04:35:12 EDT
This is somewhat misleading.

Please note that raidtools are considered obsolete.  mdadm defaults to
left-symmetric (2).

Also note this applies to RAID-6 as well as RAID-5.
Comment 3 Jeremy Katz 2004-05-18 23:26:46 EDT
Switching to madadm for FC3, changes are in CVS (which will then
follow the default of mdadm, I'm not going to change the defaults
there either since the tool should dtrt by default)

Note You need to log in before you can comment on or make changes to this bug.