Bug 1226 - Remote /usr mounting problems
Remote /usr mounting problems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
5.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-18 05:41 EST by thomas
Modified: 2014-03-16 22:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-19 16:58:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description thomas 1999-02-18 05:41:30 EST
On many Linux workstations that operates on LAN's one would
 like to mount the /usr file system over NFS to save local
 disk space.
 I've been using Slackware 3.2 before which handles this
nicely,
 but with RED HAT 5.2 the system uses files from the /usr
file
 system _BEFORE_ the remote disks have been mounted. (Which
is
 not very good. I get errors from linuxconf trying to access
 libraries that are on the /usr system (which has not been
mounted
 yet).

 Also on shutdown, a general process TERM / KILL is done
 _AFTER_ all remote file systems have been unmounted. (This,
I believe, should be done earlier, since when RED HAT tries
to unmount the remote systems this often fails with a
 "device busy" message if a user-started daemon or
 job is still running. Slightly afterwards, RED HAT shuts
 down RPC, while the backround processes are still using
NFS.
 This results in a system hang, and one more or less has
to   hard-reboot.
 Not very good.

 Regards.
 Thomas Hellstrvm
Comment 1 Bill Nottingham 1999-03-15 19:11:59 EST
what does linuxconf try to use before /usr is mounted?
Comment 2 thomas 1999-03-16 07:34:59 EST
linuxconf tries to use
/usr/lib/libncurses.so.4

If that library is put in /lib, then I get complains about
/usr/lib/libgd.so.1

If that library also is put in /lib I get complains about
a dictionnary (yes it is spelled that way) not found in
/usr/lib/linuxconf. It seems like the  dictionary really is needed :-)
Comment 3 Bill Nottingham 1999-03-16 10:45:59 EST
When are you getting the errors from linuxconf (when is
it getting invoked?)
Comment 4 thomas 1999-03-16 10:55:59 EST
I'm getting errors after the message about 'starting kerneld'
and, I think it's before 'Enabling ipv4 message forwarding', but it
coud also be just after this message (I don't have the computer
here.).
It's definitively before the network card modules are inserted and
initialized.

/Thomas
Comment 5 Bill Nottingham 1999-03-19 16:58:59 EST
fixed in initscripts-3.96-5 (don't run linuxconf if /usr is
not there...)

Note You need to log in before you can comment on or make changes to this bug.