Bug 1226017 - foreman-debug: script says it was successful even when it obv. wasn't.
Summary: foreman-debug: script says it was successful even when it obv. wasn't.
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Debug
Version: 6.1.11
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-28 18:42 UTC by Corey Welton
Modified: 2019-09-26 13:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-10 20:35:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 17771 0 None None None 2016-12-19 19:58:21 UTC

Description Corey Welton 2015-05-28 18:42:02 UTC
Description of problem:
When something disrupts an upload of a foreman debug file, script still says it is successful, even when it isn't.

Version-Release number of selected component (if applicable):

snap 6 RHEL7

How reproducible:


Steps to Reproduce:
1. foreman-debug -g -v -a -d /tmp/test
2. view results 
3. 

Actual results:

A debug directory has been created: /tmp/test

You may want to upload the tarball to our public server via rsync. There is a
write only directory (readable only by Foreman core developers) for that. Note
the rsync transmission is UNENCRYPTED:

  rsync /tmp/test.tar.xz rsync://theforeman.org/debug-incoming

Do you want to do this now? [y/N] y
Uploading...

rsync: link_stat "/tmp/test.tar.xz" failed: No such file or directory (2)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1052) [sender=3.0.9]
The tarball has been uploaded, please contact us on mailing list or IRC.

Expected results:

If there is a failure in send, it should not says "The tarball has been uploaded".


Additional info:

Comment 1 RHEL Program Management 2015-05-28 18:52:27 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2016-07-26 15:25:24 UTC
Moving 6.2 bugs out to sat-backlog.

Comment 4 Bryan Kearney 2016-07-26 15:44:48 UTC
Moving 6.2 bugs out to sat-backlog.

Comment 6 Zach Huntington-Meath 2016-12-19 19:56:22 UTC
Created redmine issue http://projects.theforeman.org/issues/17771 from this bug

Comment 7 Bryan Kearney 2017-04-10 20:35:10 UTC
This has been reported usptream as an issue, and will no longer be tracked it downstream. I am therefore closing this out. If you feel this was done incorrecty, please feel free to re-open with additional data.


Note You need to log in before you can comment on or make changes to this bug.