Bug 1226024 - cli/tiering:typo errors in tiering
Summary: cli/tiering:typo errors in tiering
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.0
Hardware: All
OS: All
high
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1227241 1260923
TreeView+ depends on / blocked
 
Reported: 2015-05-28 18:59 UTC by Mohammed Rafi KC
Modified: 2015-10-30 17:32 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1227241 (view as bug list)
Environment:
Last Closed: 2015-06-02 08:03:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-05-28 18:59:03 UTC
Description of problem:

    
    volume info shows Cold Bricks instead of Tier type
      eg:
    Volume Name: patchy2
    Type: Tier
    Volume ID: 28c25b8d-b8a1-45dc-b4b7-cbd0b344f58f
    Status: Started
    Number of Bricks: 3
    Transport-type: tcp
    Hot Tier :
    Hot Tier Type : Distribute
    Number of Bricks: 1
    Brick1: 10.70.1.35:/home/brick43
    Cold Bricks:
    Cold Tier Type : Distribute
    Number of Bricks: 2
    Brick2: 10.70.1.35:/home/brick19
    Brick3: 10.70.1.35:/home/brick16
    Options Reconfigured:
    


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-05-28 19:03:18 UTC
REVIEW: http://review.gluster.org/10978 (tiering: Correct errors in cli and glusterd) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-06-01 04:31:56 UTC
COMMIT: http://review.gluster.org/10978 committed in release-3.7 by Kaushal M (kaushal@redhat.com) 
------
commit 57abe450c1e90749a4a32247836f05b1195d5313
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed May 13 16:53:22 2015 +0530

    tiering: Correct errors in cli and glusterd
    
            Back port of http://review.gluster.org/10768
    
    Problem 1:
    
    volume info shows Cold Bricks instead of Tier type
      eg:
    Volume Name: patchy2
    Type: Tier
    Volume ID: 28c25b8d-b8a1-45dc-b4b7-cbd0b344f58f
    Status: Started
    Number of Bricks: 3
    Transport-type: tcp
    Hot Tier :
    Hot Tier Type : Distribute
    Number of Bricks: 1
    Brick1: 10.70.1.35:/home/brick43
    Cold Bricks:
    Cold Tier Type : Distribute
    Number of Bricks: 2
    Brick2: 10.70.1.35:/home/brick19
    Brick3: 10.70.1.35:/home/brick16
    Options Reconfigured:
    
    Problem 2: Detach-tier sending enums of Rebalance
    
       detach-tier has it's own Enum to send with detach-tier command,
    using that enums will make more appropriate.
    
    Problem 3:
    
    Wrongly sets hot_brick count during the dictionary copying for response
    
    >Change-Id: Icc054a999a679456881bc70511470d32ff8a86e4
    >BUG: 1211264
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/10768
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    >Reviewed-by: Kaushal M <kaushal@redhat.com>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Tested-by: NetBSD Build System
    
    Change-Id: I889d3b83a1f197b79eb71e594a1ad1f2037ed402
    BUG: 1226024
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/10978
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Joseph Fernandes
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 3 Niels de Vos 2015-06-02 08:03:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.