This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 122604 - Resume broken for HP Pavillion ZE4201
Resume broken for HP Pavillion ZE4201
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: 121020
  Show dependency treegraph
 
Reported: 2004-05-06 02:51 EDT by Bojan Smojver
Modified: 2015-01-04 17:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 00:20:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (11.11 KB, text/plain)
2004-05-06 02:52 EDT, Bojan Smojver
no flags Details
lsmod (1.17 KB, text/plain)
2004-05-06 02:53 EDT, Bojan Smojver
no flags Details
lspci -n (366 bytes, text/plain)
2004-05-06 02:53 EDT, Bojan Smojver
no flags Details
lspci (795 bytes, text/plain)
2004-05-06 02:54 EDT, Bojan Smojver
no flags Details

  None (edit)
Description Bojan Smojver 2004-05-06 02:51:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Galeon/1.3.14

Description of problem:
After entering suspend to memory with:

echo "mem" > /sys/power/state

which works OK, the notebook won't come back properly. The power comes
on but the screen remains blank. CAPS LOCK and NUM LOCK change states
fo LEDs but the keyboard does nothing else.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enter suspend to memory.
2. Try to power back up.
    

Additional info:

I'll attach files as per bug 121020.
Comment 1 Bojan Smojver 2004-05-06 02:52:44 EDT
Created attachment 100027 [details]
dmesg
Comment 2 Bojan Smojver 2004-05-06 02:53:18 EDT
Created attachment 100028 [details]
lsmod
Comment 3 Bojan Smojver 2004-05-06 02:53:44 EDT
Created attachment 100029 [details]
lspci -n
Comment 4 Bojan Smojver 2004-05-06 02:54:12 EDT
Created attachment 100030 [details]
lspci
Comment 5 Warren Togami 2004-05-11 03:11:41 EDT
Please retest with kernel-2.6.5-1.358 or newer.  There have been
several major fixes that may have improved this situation for you.  If
it fails, please retest with the same version but i586 kernel.
Comment 6 Bojan Smojver 2004-05-11 06:00:15 EDT
Nope. Same deal with 358 i686. Let me try the i586...
Comment 7 Bojan Smojver 2004-05-11 06:20:43 EDT
With i586 keyboard doesn't even respond to CAPS LOCK, NUM LOCK etc.
The lights come on (i.e. various LEDs like power button LED etc.), I
can even hear the CPU fan going after a while, but the machine is
otherwise dead. Hope this helps.

Do you need any other info about the machine's hardware?

BTW, even when I do the suspend to memory from run level 1, it does
the same thing (i.e. running X doesn't seem to be the cause of this
issue). Suspend to disk does nothing at all.
Comment 8 Bojan Smojver 2004-05-11 18:20:49 EDT
If it's of any help, the vanilla 2.6.6 does more or less the same
thing with suspend to memory. The machine goes into suspend, but when
it comes back, it is dead although the LEDs come on. No keys on the
keyboard do anything.

The main difference that I can see is that "echo disk >
/sys/power/state" in fact _does_ write something out to the swap
partition. I'm still unclear how to get that back (the resume=/dev/xxx
doesn't seem to work), but hey, it's better than nothing :-)
Comment 9 Pavel Tsekov 2004-05-26 03:07:05 EDT
Suspend-to-disk is not compiled in FC kernels for some reason. Neither
the new (/sys/power) nor the old method (/proc/acpi). I was wondering
if this issue qualifies for bugzilla entry but I guess the maintainers
had something in mind.
Comment 10 Arjan van de Ven 2004-05-26 10:12:38 EDT
suspend to disk is quite really badly broken unfortinalty.

Ok new kernel uploaded to http://people.redhat.com/arjanv/2.6
it works better for my machine, but I do have to unload the ehci_hcd
module before i can suspend for some reason (still investigating that)
Comment 11 Bojan Smojver 2004-06-14 17:09:39 EDT
Just FYI, kernel-2.6.6-1.435 is still a no go on this notebook. 
Comment 12 Bojan Smojver 2004-08-24 17:49:00 EDT
Kernel 2.6.8-1.521 still doesn't do this right.
Comment 13 Bojan Smojver 2004-10-10 16:11:00 EDT
Still the case with FC3T2, kernel 2.6.8-1.603.
Comment 14 Warren Togami 2004-10-10 18:25:51 EDT
Please do not expect us to investigate your issue.  You must push
upstream kernel.org and use bugzilla.kernel.org.  If they manage to
fix this, then the FC kernel will have it when we upgrade to the
latest upstream kernel.
Comment 15 Bojan Smojver 2004-10-10 21:41:57 EDT
I was just reporting this so that we have a full history of it. But,
if you don't wan't me to do that, I can stop.
Comment 16 Warren Togami 2004-10-11 01:19:53 EDT
Reporting is fine, so others see this report.  But if you want a
solution, bugzilla.kernel.org and the upstream ACPI project is where
you must seek help.
Comment 17 Bojan Smojver 2004-10-11 16:22:28 EDT
No worries. Shall open one today and post a link to it here.
Comment 18 Bojan Smojver 2004-10-12 07:46:34 EDT
Kernel bug: http://bugzilla.kernel.org/show_bug.cgi?id=3556
Comment 19 Bojan Smojver 2005-05-11 00:20:14 EDT
suspend2 works fine, so I'll close this. It seems video related anyway - radeon
driver needs to soft boot the cards or something like that.

Note You need to log in before you can comment on or make changes to this bug.