Bug 122609 - (FUTEX) Multiple kernel freezes during normal use
(FUTEX) Multiple kernel freezes during normal use
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 05:31 EDT by Neil Thompson
Modified: 2015-01-04 17:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 11:26:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Oopses and log messages from the freezes I've had (8.36 KB, text/plain)
2004-05-06 05:33 EDT, Neil Thompson
no flags Details
Another oops, this time on 1.353 (4.74 KB, text/plain)
2004-05-08 07:53 EDT, Neil Thompson
no flags Details
Another oops (2.47 KB, text/plain)
2004-05-10 15:15 EDT, Neil Thompson
no flags Details
oops on freeze kernel 1.358 (4.74 KB, text/plain)
2004-05-10 15:31 EDT, Neil Thompson
no flags Details
another oops on 2.6.5-1.358 (1.06 KB, text/plain)
2004-05-19 14:38 EDT, Neil Thompson
no flags Details
lspci and lsmod as requested (9.53 KB, text/plain)
2004-05-22 11:09 EDT, Neil Thompson
no flags Details

  None (edit)
Description Neil Thompson 2004-05-06 05:31:22 EDT
Description of problem:

Since installing FC2T3 (clean install) I have been experiencing
regular freezes.  This has gotten worse since upgrading to kernel
1.250. I have had five this morning already.  This is using an ASUS
A7V600 board, Athlon 2400+, 512Mb RAM, and a Radeon 9200SE video card.
 The freezes only happen when I'm in X - if I'm on the console or
ssh'd in, the machine is stable.  I'm running with SELinux in
permissive mode.   
 



Version-Release number of selected component (if applicable):

kernel-2.6.5-1.250

How reproducible:

Always when using X

Steps to Reproduce:

Normal use - generally when typing or moving mouse
  
Actual results:


Expected results:


Additional info:
Comment 1 Neil Thompson 2004-05-06 05:33:52 EDT
Created attachment 100035 [details]
Oopses and log messages from the freezes I've had
Comment 2 Neil Thompson 2004-05-06 11:42:09 EDT
Stupid me, in between all my crashes I got the version wrong - I was
actually on 1.350, not 1.250 - makes a bit of a difference.  I have
just upgraded to 1.351, we'll see what happens.
Comment 3 Neil Thompson 2004-05-06 15:56:04 EDT
Several more freezes on 1.351 - nothing in the logs.  Tuxracer kills
the box every time.
Comment 4 Pascal Volk 2004-05-07 09:40:01 EDT
Same problem here with kernel 2.6.5-1.349 and 2.6.5-1.351. The system
freezes after different time. All the same whether KDE or XFce is
used. In the log files nothing is to be found.
SELinux is turned off.

Hardware:
Board: MSI K7N2
CPU: AMD Athlon(tm) XP 2000+
RAM: 512 MB SD-DDR

If further information should be necessary, ask me simply.

Is it an ACPI-problem?
Comment 5 Neil Thompson 2004-05-08 07:53:36 EDT
Created attachment 100107 [details]
Another oops, this time on 1.353

Still freezing on 1.353.  Please note that the machine is completely stable
under fairly heavy load (MailScanner with clamav and spamassassin with a good
deal of email coming in) as long as there is no interaction with X.
Comment 6 Neil Thompson 2004-05-10 15:15:47 EDT
Created attachment 100141 [details]
Another oops

X restarted with this oops - no freeze
Comment 7 Neil Thompson 2004-05-10 15:31:28 EDT
Created attachment 100142 [details]
oops on freeze kernel 1.358

Another oops - immediately after previous - with freeze - on 1.358
Comment 8 Neil Thompson 2004-05-19 14:38:01 EDT
Created attachment 100354 [details]
another oops on 2.6.5-1.358

I have now disabled selinux completely - still freezing/crashing regularly. 
Sometimes with a log entry and sometimes without.  Here's the latest.  I'm
starting to get a little despondent - this feels like kernel 0.99.<mumble>,
which was the first one I used.

Is anyone listening?
Comment 9 Maciej Żenczykowski 2004-05-20 18:37:40 EDT
--- FC2: Sun Java 1.4.2_04 futex freeze ---
P3 1GHz, 512MB, freshly upgraded to FC2, kernel 2.6.5-1.358
Sun Java 1.4.2_04 freezes entire kernel, alt+sysrq displays info on
screen but sync and unmount and poweroff and term and kill don't do
anything.  Note: no oops, just freeze!

appears to be a problem (according to tasks) with java calling
sys_futex and looping in restoresigcontext (according to showpc). Need
more data?
Comment 10 Alan Cox 2004-05-21 20:21:39 EDT
Does this occur if you add and run the i586 kernel ?
Comment 11 Neil Thompson 2004-05-22 10:04:30 EDT
I've added the i586 kernel, rebooted to it and banged on the box for
about an hour - no freezing yet.

Another datum is that I've just built a clone of the box that's
failing and the new box is completely stable, so it is probably
something to do with the old box - although the old box was stable
under FC1.
Comment 12 Alan Cox 2004-05-22 10:42:05 EDT
The java case is a specific bug currently being tracked. A possible
fix is being looked at now ready for the first FC2 errata kernel.

The other one is more curious. The i586 kernel changes a couple of
things - it means that memory isnt hit as hard (no fancy memory
copying functions for Athlon), and it means that certain kinds of
device driver error that were not a problem in 2.4 will also continue
to work (including the java bug...).

I'd thus be interested in a full list of hardware on the machine
(lspci -vxx and lsmod attachment would be great) - and if you too are
running the Sun java tools. Also to eliminate one other thing - does
it work reliably using the vesa X server ?



Comment 13 Neil Thompson 2004-05-22 11:09:31 EDT
Created attachment 100453 [details]
lspci and lsmod as requested

I've managed to trigger the fault on the i586 kernel (tuxracer will do it every
time).	Now that I have a second machine to play with, I've been able to ssh
into the affected machine - it's not frozen at all.  It's just X that has
stopped working.  Is there anything I can get from the box while it is in this
state that would help?
Comment 14 Pascal Volk 2004-05-22 13:06:32 EDT
I've tested a lot (kernel-2.6.5-1.358 and a vanilla kernel-2.6.6). I
think it's a problem with KDE and X.org.

If my box is running in runlevel 3 everything is fine. A system load
greater than 2 is no problem.
In runlevel 5 (with a XFce-session) also everything is fine, but when
I'm starting a KDE application, like KMail, the system freezes.
By way of trial the x-server was also started again, before KMail or
konqueror was started. The same result - the sysytem freezes.
Gnome applications don't cause problems.
Comment 15 Neil Thompson 2004-05-22 15:28:47 EDT
I don't run KDE at all, just Gnome, so that's out.
Comment 16 Pascal Volk 2004-05-22 16:37:10 EDT
OK, XFce, (Gnome) and the kernel-2.6.5-1.358 is enough - the system
will freeze after a few minutes.
In the past days the system ran only with the vanilla kernel. With
this there were only in connection with KDE applications problems.

Which informations should I supply, so that the problem can be solved
as soon as possible?
Comment 17 Dave Jones 2004-11-29 05:02:51 EST
any better with the 2.6.9 errata kernel?
Comment 18 Neil Thompson 2004-11-29 05:27:17 EST
I eventually gave up and installed XP on the box for my daughter - just before
the 2.6.9 kernel came out.  That didn't work too well either, and I replaced the
motherboard.  Before that I had managed to reduce the occurrence of the problem
by moving the USB mouse and keyboard around on the various USB connectors on the
box.  Removing the USB Keyboard completely reduced the freezes to about once a
day - provided I could get the box up in the first place.  The USB keyboard also
caused intermittant problems with the new motherboard.

I'd probably put it down to a flaky hardware combination. 

Note You need to log in before you can comment on or make changes to this bug.