This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 12261 - No libXaw3d.so.6
No libXaw3d.so.6
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xaw3d (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-14 11:31 EDT by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-14 11:31:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-06-14 11:31:41 EDT
XFree86-libs-4.0 contain both libAw.so.7 and libAw.so.6 libs for backward
compatibility. Xaw3d is also upgraded to version 7, but doesn't have an
backward compatibilty lib. This bit me when install xawtv from the 6.2
powertools CD, and will very probably also bite other external RPMS.

I've solved it by adding a symlink and using --nodeps. The real fix would
then ofcourse be to rebuild Xaw3d and list libXaw.so.6 as a provide.

I dunno if this is correct though, since there might have been some api
changes, this however works for me (TM)
Comment 1 Ngo Than 2000-06-25 06:24:56 EDT
It was fixed. I have added the backward compatibility library Xaw3d.so.6.

Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.