Bug 122612 - Epson CX5400 is not available
Epson CX5400 is not available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 05:51 EDT by Dimitris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.0.1-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-20 12:12:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitris 2004-05-06 05:51:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
The Epson Stylus CX-5400 printer is not available from the
list of Epson printers.

The CX-5400 was included in gimp-print and the other printing
utils and databases some months ago before fedora test2 was
out, but the system-config-printer still does not list
the CX-5400.

It is important to list the CX-5400 because its not like
the CX-5200 which has a slower engine. The CX-5400 instead
uses the C84 engine which does 22ppm instead of 12ppm.

Thank you.


Version-Release number of selected component (if applicable):
system-config-printer 0.6.98-1

How reproducible:
Always

Steps to Reproduce:
1. login as root
2. run system-config-printer
3. add new printer, select Epson, search list of CX-5400
    

Actual Results:  The CX-5400 isn't there.

Expected Results:  The CX-5400 should be listed.

Additional info:

None.
Comment 1 Tim Waugh 2004-05-06 06:03:59 EDT
You need to get it listed on www.linuxprinting.org, and then we can
import the data into foomatic.
Comment 2 Dimitris 2004-05-06 06:16:11 EDT
Its already listed.. it was added months ago:

http://www.linuxprinting.org/show_printer.cgi?recnum=Epson-Stylus_CX5400
Comment 3 Tim Waugh 2004-05-06 06:19:05 EDT
Oops, I'd been looking for '4500' not '5400'.  Thanks.
Comment 4 Dimitris 2004-05-06 06:20:14 EDT
Please note; the document lists the usb id as '0x4b8 0x805' which is
NOT correct.

The correct usb id for the CX5400, as noted further down by the user
comments, is: 0x4b8 0x808

Thank you, your quick responce is much appriciated.
Comment 5 Tim Waugh 2004-05-06 06:59:38 EDT
Hmm, although the printer/Epson-Stylus_CX5400.xml file is there, its
ID isn't listed in driver/gimp-print.xml.

In fact -- it's already there in our foomatic package.  So it looks
like /usr/share/foomatic/db/source/driver/gimp-print-ijs.xml is just
missing some lines like:

  <!-- gimp-print driver: escp2-c84 -->
  <printer>
    <id>printer/Epson-Stylus_C84</id>
    <margins>
      <general>
        <relative />
        <left>9</left>
        <right>9</right>
        <top>0</top>
        <bottom>9</bottom>
      </general>
    </margins>
  </printer>

Can you try that?
Comment 6 Dimitris 2004-05-06 08:23:13 EDT
There is definetly something wrong here.

I added the following (changed the CX5200 to CX5400, since its similar
to the C84 lines above):

  <!-- gimp-print driver: escp2-cx5400 -->
  <printer>
    <id>printer/Epson-Stylus_CX5400</id>
    <margins>
      <general>
        <relative />
        <left>9</left>
        <right>9</right>
        <top>0</top>
        <bottom>9</bottom>
      </general>
    </margins>
  </printer>

Now, the CX5400 comes up in the system-redhat-config, unfortunately
it seems its missing all its options under the "Driver Options" tab.

If i select the C84 or the CX5200 (slower model), then under
"Driver Options" there are a wide range of settings to select
the different printing methods etc.

When i added the above lines in gimp-print-ijs.xml, and selected
the newly appeared CX5400 printer, those options are no longer
there, instead there are just 5-6 generic options.
Comment 7 Tim Waugh 2004-05-06 08:30:30 EDT
The ID will need adding to some of the files in opt/*.xml too then. 
This is something that will need to be fixed upstream in foomatic.
(It's quite late for this sort of change before FC2 now though.)

I've reported it upstream.
Comment 8 Dimitris 2004-05-06 10:58:25 EDT
oh damn, i was hoping to get this working for FC2 :(

thanks for the help though
Comment 9 Till Kamppeter 2004-05-08 16:55:00 EDT
The gimp-print.xml is a pseudo entry only telling that the Gimp-Print
driver exists and which printers work with it. It does not produce any
PPD files. The "real" Foomatic data for Gimp-Print is produced by
Gimp-Print and therefore part of the Gimp-Print package. You have to
compile Gimp-Print with the IJS interface (should be done
automatically when libijs-devel is installed) and generation of
Foomatic data (will be done automatically when Foomatic is installed
on the system). The "make install" of Gimp-Print installs Foomatic
data for the "gimp-print-ijs" driver which allows generating a PPD
file also for the CX5400. The "gimp-print.xml" from Foomatic can be
deleted then.

Note that the "gimp-print.xml" on linuxprinting.org describes
Gimp-Print 4.2.6 and the CX5400 support was introduced only in 4.2.7.
So you should use the latest RC of 4.2.7.
Comment 10 Dimitris 2004-05-08 18:03:39 EDT
So in other words, installing 4.2.7 will solve my problem and the
printer will be detected and properly appear in the print manager?

I checked FC2 test3 and its still using 4.2.6 :(
Comment 11 Till Kamppeter 2004-05-08 18:30:30 EDT
Yes, it should. And if the update deadline for FC2 is already over, I
recommend that a Gimp-Print 4.2.7 update package should be put out,
simply as ipdate to support the latest hardware.
Comment 12 Dimitris 2004-05-08 19:46:24 EDT
I've been waiting to get this printer supported since the end
of october 2003 when i was using FC1 test3 :(

i opened a bug report back then and i was told the printer
was 'added'. something which never happened i guess.

an updated package would be much appriciated.

thank you.
Comment 13 Tim Waugh 2004-05-09 06:19:10 EDT
Thanks for the clarifications.  Well, it's definitely too late to bump
version numbers in packages for FC2.
Comment 14 Dimitris 2004-07-02 01:47:28 EDT
Is it too late for FC3 test1?
Comment 15 Tim Waugh 2004-07-02 04:57:34 EDT
gimp-print 4.2.7 has not yet been released.
Comment 16 Dimitris 2004-07-18 07:12:28 EDT
As of the 15th of July, gimp-print 4.2.7 is out:

http://sourceforge.net/mailarchive/message.php?msg_id=8970417

:)
Comment 17 Tim Waugh 2004-07-20 12:12:36 EDT
foomatic-3.0.1-7 will have the gimp-print 4.2.7 data.

Note You need to log in before you can comment on or make changes to this bug.