Bug 1226120 - [Snapshot] Do not run scheduler if ovirt scheduler is running
Summary: [Snapshot] Do not run scheduler if ovirt scheduler is running
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard: Scheduler
Depends On: 1219442
Blocks: qe_tracker_everglades glusterfs-3.7.1 1223209
TreeView+ depends on / blocked
 
Reported: 2015-05-29 03:11 UTC by Avra Sengupta
Modified: 2015-06-02 08:24 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1219442
Environment:
Last Closed: 2015-06-02 08:04:02 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Avra Sengupta 2015-05-29 03:11:09 UTC
+++ This bug was initially created as a clone of Bug #1219442 +++

Description of problem:
Do not run scheduler if ovirt scheduler is running

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-05-07 08:54:05 EDT ---

REVIEW: http://review.gluster.org/10641 (snapshot/scheduler: Do not enable scheduler if another scheduler is running) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-12 02:24:45 EDT ---

REVIEW: http://review.gluster.org/10641 (snapshot/scheduler: Do not enable scheduler if another scheduler is running) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-12 03:34:31 EDT ---

REVIEW: http://review.gluster.org/10641 (snapshot/scheduler: Do not enable scheduler if another scheduler is running) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-28 00:55:39 EDT ---

REVIEW: http://review.gluster.org/10641 (snapshot/scheduler: Do not enable scheduler if another scheduler is running) posted (#5) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Anand Avati on 2015-05-28 22:25:42 EDT ---

COMMIT: http://review.gluster.org/10641 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit d67eb34b2a5b5e3cb926ff4c86a163148743829c
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Thu May 7 17:50:25 2015 +0530

    snapshot/scheduler: Do not enable scheduler if another scheduler is running
    
    Check if another snapshot scheduler is running before
    enabling the scheduler.
    
    Also introducing a hidden option, disable_force
    
    "snapshot_scheduler.py disable_force" will disable the
    cli snapshot scheduler from any node, even though the node
    has not been initialised for the scheduler, as long as the
    shared storage is mounted
    
    This option is hidden, because we don't want to encourage
    users to use all commands from nodes that are not initialised.
    
    Change-Id: I7ad941fbbab834225a36e740c61f8e740813e7c8
    BUG: 1219442
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/10641
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Tested-by: NetBSD Build System
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 1 Avra Sengupta 2015-05-29 08:40:04 UTC
Patch at http://review.gluster.org/#/c/10993/

Comment 2 Anand Avati 2015-06-01 06:26:26 UTC
REVIEW: http://review.gluster.org/10993 (snapshot/scheduler: Do not enable scheduler if another scheduler is running) posted (#2) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 3 Anand Avati 2015-06-01 11:14:16 UTC
COMMIT: http://review.gluster.org/10993 committed in release-3.7 by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit fd5fc2209b9206f36fe04c528cbd9f43689b765b
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Thu May 7 17:50:25 2015 +0530

    snapshot/scheduler: Do not enable scheduler if another scheduler is running
    
         Backport of http://review.gluster.org/#/c/10641/
    
    Check if another snapshot scheduler is running before
    enabling the scheduler
    
    Also introducing a hidden option, disable_force
    
    "snapshot_scheduler.py disable_force" will disable the
    cli snapshot scheduler from any node, even though the node
    has not been initialised for the scheduler, as long as the
    shared storage is mounted
    
    This option is hidden, because we don't want to encourage
    users to use all commands from nodes that are not initialised.
    
    Change-Id: I7ad941fbbab834225a36e740c61f8e740813e7c8
    BUG: 1226120
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/10641
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Tested-by: NetBSD Build System
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    (cherry picked from commit d67eb34b2a5b5e3cb926ff4c86a163148743829c)
    Reviewed-on: http://review.gluster.org/10993
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 4 Niels de Vos 2015-06-02 08:04:02 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.