Bug 1226279 - GF_CONTENT_KEY should not be handled unless we are sure no other operations are in progress
Summary: GF_CONTENT_KEY should not be handled unless we are sure no other operations a...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1243642
TreeView+ depends on / blocked
 
Reported: 2015-05-29 11:19 UTC by Pranith Kumar K
Modified: 2016-06-16 13:06 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1243642 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:06:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2015-05-29 11:19:14 UTC
Description of problem:
GF_CONTENT_KEY aggregation requires that the fragments on the bricks belong to same data i.e. no operations are modifying the content while lookup is performed on it. The only way to know it is to get at least ec->fragments+1 number of responses and see that two different sets of ec->fragments number of fragments give same data. But at the moment we feel that this slows down ec-lookup. So removing handling of this for now.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-05-29 11:21:31 UTC
REVIEW: http://review.gluster.org/11003 (cluster/ec: Do not handle GF_CONTENT_KEY) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2015-06-04 02:46:15 UTC
REVIEW: http://review.gluster.org/11003 (cluster/ec: Do not handle GF_CONTENT_KEY) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Anand Avati 2015-06-23 09:13:43 UTC
COMMIT: http://review.gluster.org/11003 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 653d3c1406e372aabcf694bfead2d695f84ee0f8
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu May 28 15:33:18 2015 +0530

    cluster/ec: Do not handle GF_CONTENT_KEY
    
    GF_CONTENT_KEY aggregation requires that the fragments on the bricks belong to
    same data i.e. no operations are modifying the content while lookup is
    performed on it. The only way to know it is to get at least ec->fragments+1
    number of responses and see that two different sets of ec->fragments number of
    fragments give same data. But at the moment we feel that this slows down
    ec-lookup. So removing handling of this for now.
    
    Change-Id: I2da5087f1311d5cdde999062607b143b48c17713
    BUG: 1226279
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11003
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 4 Nagaprasad Sathyanarayana 2015-10-25 15:09:18 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 5 Niels de Vos 2016-06-16 13:06:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.