Bug 122630 - Nautilus attempts to access/remount previously mounted file systems at startup
Summary: Nautilus attempts to access/remount previously mounted file systems at startup
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-vfs2 (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 132991
TreeView+ depends on / blocked
 
Reported: 2004-05-06 14:34 UTC by Pancrazio `ezio' de Mauro
Modified: 2015-01-08 00:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 13:45:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch applied to cvs (2.18 KB, patch)
2004-08-30 10:22 UTC, Alexander Larsson
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:148 normal SHIPPED_LIVE gnome-vfs2 bug fix update 2005-05-19 04:00:00 UTC

Description Pancrazio `ezio' de Mauro 2004-05-06 14:34:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7 StumbleUpon/1.89

Description of problem:
Nautilus regularly watches the list of mounted file systems and keeps
track of them in ~/.gnome/gnome-vfs/.trash_entry_cache and it attempts
to access/mount those file systems at startup.

The problem is that nautilus doesn't seem to delete entries from that
file, once the related file system is unmounted.

This interacts very badly with temporary mounts (e.g. usb removable
media) and automounts, especially NFS ones: when nautilus starts at
the next session, it attempts to remount whatever was accumulated in
~/.gnome/gnome-vfs/.trash_entry_cache

Version-Release number of selected component (if applicable):
nautilus-2.2.4-4.E

How reproducible:
Always

Steps to Reproduce:
1. start nautilus
2. access an automounted file system
3. umount that filesystem or wait for the automatic umount
4. close nautilus
5. start nautilus
    

Actual Results:  nautilus will attempt to remount that file system
even though it wasn't mounted anymore when nautilus last exited. If
the mountpoint is for an NFS file system residing on a server which is
now down, huge timeouts may occur before nautilus completes its startup


Expected Results:  nautilus should remove umounted entries from
~/.gnome/gnome-vfs/.trash_entry_cache so that they are not
accessed/remounted at the next startup

Additional info:

Comment 2 Franco M. Bladilo 2004-05-11 19:48:41 UTC
Any updates on this?
We are experiencing this same problem on a considerable number of
machines (RHEL3 and RH9), graphical logins sometimes take 2/5 minutes.

Thanks.



Comment 3 Alexander Larsson 2004-08-26 15:02:56 UTC
I killed all this upstream. The cache of trash directories wasn't
needed anymore anyway, since we don't search for trash directories
anymore.

The fix will be in rawhide when we build the next gnome-vfs2 release,
and in the next RHEL release after that.

Comment 5 Alexander Larsson 2004-08-27 16:00:13 UTC
Actually, i had to back that change out as it broke some stuff. It
requires some more investigation unfortunately.

Comment 6 Alexander Larsson 2004-08-30 10:22:09 UTC
Created attachment 103237 [details]
patch applied to cvs

I commited this patch to gnome-vfs HEAD, which will end up in gnome 2.8 and in
the next release based on it.

Can you test it and see if it helps for this problem?

Comment 12 John (J5) Palmieri 2005-02-10 00:25:36 UTC
Patched and building as errata

Comment 13 John (J5) Palmieri 2005-02-10 01:24:46 UTC
Errata submitted

Comment 14 Tim Powers 2005-05-19 13:45:04 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-148.html



Note You need to log in before you can comment on or make changes to this bug.