Bug 1226384 - build: xlators/mgmt/glusterd/src/glusterd-errno.h is not in dist tarball
Summary: build: xlators/mgmt/glusterd/src/glusterd-errno.h is not in dist tarball
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1226404
TreeView+ depends on / blocked
 
Reported: 2015-05-29 15:30 UTC by Kaleb KEITHLEY
Modified: 2016-06-16 13:06 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1226404 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:06:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2015-05-29 15:30:42 UTC
Description of problem:

Version-Release number of selected component (if applicable):


How reproducible:

`make -C extras/LinuxRPM glusterrpms` fails with glusterd-locks.c:19:28: fatal error: glusterd-errno.h: No such file or directory compilation terminated.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-05-29 15:37:19 UTC
REVIEW: http://review.gluster.org/11007 (build: xlators/mgmt/glusterd/src/glusterd-errno.h is not in dist tarball) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Anand Avati 2015-05-30 03:30:56 UTC
COMMIT: http://review.gluster.org/11007 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 8772ca6c559623e96bbdd40811d8ec25210810fc
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Fri May 29 11:34:38 2015 -0400

    build: xlators/mgmt/glusterd/src/glusterd-errno.h is not in dist tarball
    
    attempts to build RPMs, e.g. in tree with `make -C extras/LinuxRPM
    glusterrpms` or from a dist tarball produced in tree will fail with:
    
    glusterd-locks.c:19:28: fatal error: glusterd-errno.h: No such file
    or directory compilation terminated
    
    Change-Id: I365dbcd5b7bc3410f4a7752a05f570e4061461d0
    BUG: 1226384
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/11007
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 3 Niels de Vos 2016-06-16 13:06:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.