Bug 1226426 - [abrt] gnome-software: strlen(): gnome-software killed by SIGSEGV
Summary: [abrt] gnome-software: strlen(): gnome-software killed by SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:d5bf09789fe2966e1ffb54a58b1...
: 1224809 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-29 18:10 UTC by 123
Modified: 2015-06-21 00:06 UTC (History)
4 users (show)

Fixed In Version: gnome-software-3.14.5-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-11 18:32:15 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (27.61 KB, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details
File: build_ids (5.25 KB, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details
File: cgroup (190 bytes, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details
File: core_backtrace (12.65 KB, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details
File: dso_list (13.67 KB, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details
File: environ (1.67 KB, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details
File: limits (1.29 KB, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details
File: maps (66.75 KB, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details
File: mountinfo (3.57 KB, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details
File: namespaces (85 bytes, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details
File: open_fds (1.71 KB, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details
File: proc_pid_status (968 bytes, text/plain)
2015-05-29 18:10 UTC, 123
no flags Details

Description 123 2015-05-29 18:10:36 UTC
Version-Release number of selected component:
gnome-software-3.16.2-2.fc22

Additional info:
reporter:       libreport-2.5.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: strlen
executable:     /usr/bin/gnome-software
global_pid:     1998
kernel:         4.0.4-301.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000
var_log_messages: [System Logs]:\n-- Logs begin at Чт 2015-05-28 10:24:10 MSK, end at Пт 2015-05-29 20:45:25 MSK. --

Truncated backtrace:
Thread no. 1 (6 frames)
 #0 strlen at ../sysdeps/x86_64/strlen.S:106
 #1 gs_plugin_packagekit_refresh_set_text at gs-plugin-packagekit-refresh.c:168
 #2 gs_plugin_filename_to_app at gs-plugin-packagekit-refresh.c:308
 #3 gs_plugin_loader_filename_to_app_thread_cb at gs-plugin-loader.c:3591
 #4 g_task_thread_pool_thread at gtask.c:1231
 #6 g_thread_proxy at gthread.c:764

Potential duplicate: bug 1224809

Comment 1 123 2015-05-29 18:10:39 UTC
Created attachment 1032228 [details]
File: backtrace

Comment 2 123 2015-05-29 18:10:40 UTC
Created attachment 1032229 [details]
File: build_ids

Comment 3 123 2015-05-29 18:10:41 UTC
Created attachment 1032230 [details]
File: cgroup

Comment 4 123 2015-05-29 18:10:43 UTC
Created attachment 1032231 [details]
File: core_backtrace

Comment 5 123 2015-05-29 18:10:44 UTC
Created attachment 1032232 [details]
File: dso_list

Comment 6 123 2015-05-29 18:10:46 UTC
Created attachment 1032233 [details]
File: environ

Comment 7 123 2015-05-29 18:10:47 UTC
Created attachment 1032234 [details]
File: limits

Comment 8 123 2015-05-29 18:10:49 UTC
Created attachment 1032235 [details]
File: maps

Comment 9 123 2015-05-29 18:10:51 UTC
Created attachment 1032236 [details]
File: mountinfo

Comment 10 123 2015-05-29 18:10:52 UTC
Created attachment 1032237 [details]
File: namespaces

Comment 11 123 2015-05-29 18:10:53 UTC
Created attachment 1032238 [details]
File: open_fds

Comment 12 123 2015-05-29 18:10:54 UTC
Created attachment 1032239 [details]
File: proc_pid_status

Comment 13 Kalev Lember 2015-06-03 14:39:41 UTC
*** Bug 1224809 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2015-06-05 22:05:35 UTC
gnome-software-3.16.3-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gnome-software-3.16.3-1.fc22

Comment 16 Fedora Update System 2015-06-06 18:11:54 UTC
gnome-software-3.14.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gnome-software-3.14.5-1.fc21

Comment 17 Fedora Update System 2015-06-07 15:58:33 UTC
Package gnome-software-3.14.5-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-software-3.14.5-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9570/gnome-software-3.14.5-1.fc21
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2015-06-11 18:32:15 UTC
gnome-software-3.16.3-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2015-06-21 00:06:48 UTC
gnome-software-3.14.5-2.fc21, PackageKit-1.0.6-1.fc21, libhif-0.2.0-3.fc21, libappstream-glib-0.4.0-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.