Bug 1226433 - Font rendering in the terminal emulator is broken
Summary: Font rendering in the terminal emulator is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 22
Hardware: x86_64
OS: Other
unspecified
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-29 18:42 UTC by Andrew Filippov
Modified: 2015-06-05 23:53 UTC (History)
11 users (show)

Fixed In Version: fontconfig-2.11.94-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-05 23:53:51 UTC


Attachments (Terms of Use)
Broken render (115.86 KB, image/png)
2015-05-29 18:42 UTC, Andrew Filippov
no flags Details
fontconfig patterns (4.50 KB, text/plain)
2015-06-01 15:34 UTC, Marek Kašík
no flags Details

Description Andrew Filippov 2015-05-29 18:42:26 UTC
Created attachment 1032273 [details]
Broken render

Description of problem:

Font rendering in the terminal emulator is broken. 


Version-Release number of selected component (if applicable):

Fedora 22, 


How reproducible:

Change the font in the terminal on  Terminus 15. The font will be blurred, incorrectly rendered. This is illustrated by the attached files


Steps to Reproduce:
1. Open terminal emulator
2. Change the font to Terminus 15

Actual Results:  All characters are garbled, blurred.

Expected Results:  Clear font rendering.

Additional info: see attachment

Comment 1 Marek Kašík 2015-06-01 15:34:18 UTC
Created attachment 1033398 [details]
fontconfig patterns

This is probably not a bug. But I'm not sure so I'm reassigning this to fontconfig for their expertise (if this is a bug then a fontconfig one from my point of view).

Basically you are doing this:

pango-view --dpi=96 --font="Terminus 15" --text="[int13h@d500 ~]$ fc-ca" --background=black --foreground=gray

For which fontconfig returns this font '/usr/share/fonts/terminus/ter-116n.pcf.gz' (size 16). I'm not sure why it doesn't return the '/usr/share/fonts/terminus/ter-120n.pcf.gz' because it is 72dpi equivalent of the font of size of 15 for 96dpi.

I've printed FcPattern passed to fontconfig and the resulting FcPattern in pango's pango_fc_patterns_get_font_pattern() function. You can find them in the attached file. The file shows that fontconfig actually gives us the font of size 16 even if we pass to it request for a font of pixel size 20 (size 15).

Comment 2 Fedora Update System 2015-06-02 09:38:11 UTC
fontconfig-2.11.94-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/fontconfig-2.11.94-1.fc22

Comment 3 Fedora Update System 2015-06-04 20:16:01 UTC
Package fontconfig-2.11.94-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fontconfig-2.11.94-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9400/fontconfig-2.11.94-1.fc22
then log in and leave karma (feedback).

Comment 4 clee 2015-06-05 15:46:41 UTC
fontconfig-2.11.94-1.fc22 appears to fix the font issues I was having (broken embedded bitmap fonts inside TTF/OTF files). Hooray!

Comment 5 Fedora Update System 2015-06-05 23:53:51 UTC
fontconfig-2.11.94-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.