Bug 122644 - mozilla command loads a firefox window when firefox is open
mozilla command loads a firefox window when firefox is open
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 11:55 EDT by Brian "netdragon" Bober
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-10 15:36:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian "netdragon" Bober 2004-05-06 11:55:39 EDT
fedora core 2 test 3

Description of problem:
When running firefox, if I type "mozilla", it'll load another firefox
window. I have the solution below.

Version-Release number of selected component (if applicable):
mozilla-1.6-4

How reproducible:
Always

Steps to Reproduce:
1. Run firefox
2. type mozilla in xterm
  
Actual results:

Firefox window opens

Expected results:

Mozilla window opens

Additional info:

When not running Mozilla, Firefox loads fine.

(~)> which mozilla
/usr/bin/mozilla

(/usr/lib/mozilla-1.6)> ./run-mozilla.sh
loads Mozilla

The problem is shown here:
(~)> echo $?
0
(~)> /usr/lib/mozilla-1.6/mozilla-xremote-client -a mozilla 'ping()'
2>/dev/null >/dev/null
(~)> echo $? 
2

This is the problem line:
$MOZ_CLIENT_PROGRAM 'ping()' 2>/dev/null >/dev/null

Here is the diff:
--- mozilla.old 2004-05-06 12:00:36.636278662 -0400
+++ /usr/bin/mozilla    2004-05-06 11:59:34.216785776 -0400
@@ -130,7 +130,7 @@
 }
  
 function check_running() {
-    $MOZ_CLIENT_PROGRAM 'ping()' 2>/dev/null >/dev/null
+    $MOZ_CLIENT_PROGRAM 'ping()' -a mozilla 2>/dev/null >/dev/null
     RETURN_VAL=$?
     if [ "$RETURN_VAL" -eq "2" ]; then
       echo 0
Comment 1 Christopher Blizzard 2004-05-10 15:36:49 EDT
I changed $MOZ_CLIENT_PROGRAM to just include the -a mozilla in the
1.6-7 build.  This should be fixed now.

Note You need to log in before you can comment on or make changes to this bug.