Bug 1226498 - Satellite email notifications show attachments - Unknown <text/plain>
Summary: Satellite email notifications show attachments - Unknown <text/plain>
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Email
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-30 01:33 UTC by sthirugn@redhat.com
Modified: 2019-09-26 18:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:52:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
email screenshot (103.04 KB, image/png)
2015-05-30 01:35 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description sthirugn@redhat.com 2015-05-30 01:33:00 UTC
Created attachment 1032341 [details]
email screenshot

Description of problem:
Satellite email notifications show attachments - Unknown <text/plain> 

Version-Release number of selected component (if applicable):
Satellite 6.1 GA Snap 6

How reproducible:
Always

Steps to Reproduce:
1. Trigger an email notification through Satellite - Choose anything from
    - Puppet error state
    - Satellite promote errata
    - Satellite sync errata
    - Puppet summary
    - Satellite host advisory
2. Review the email

Actual results:
Email contains an attachment - Unknown <text/plain>  (screenshot attached)

Expected results:
The attachments should not be shown

Additional info:

Comment 1 sthirugn@redhat.com 2015-05-30 01:35:03 UTC
Created attachment 1032342 [details]
email screenshot

Comment 3 Stephen Benjamin 2016-02-11 17:32:33 UTC
ActionMailer in Rails 4 correctly sets Content-Type to multipart/alternative, so this is no longer be the case in Satellite 6.2.

Comment 5 sthirugn@redhat.com 2016-03-18 19:50:39 UTC
Verified in Satellite 6.2.0-beta-snap4

Comment 8 errata-xmlrpc 2016-07-27 08:52:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.