Bug 1226551 - libglusterfs: Copy _all_ members of gf_dirent_t in entry_copy()
Summary: libglusterfs: Copy _all_ members of gf_dirent_t in entry_copy()
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1227576
TreeView+ depends on / blocked
 
Reported: 2015-05-30 14:26 UTC by Krutika Dhananjay
Modified: 2016-06-16 13:06 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1227576 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:06:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2015-05-30 14:26:40 UTC
Description of problem:

Per discussion @ http://review.gluster.org/#/c/10809/1/xlators/features/shard/src/shard.c, the function entry_copy() must also copy d_len member and the per-entry dict if it is present, into the dst dirent.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-06-01 06:41:20 UTC
REVIEW: http://review.gluster.org/11026 (libglusterfs: Copy d_len and dict as well into dst dirent) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Anand Avati 2015-06-01 11:23:36 UTC
REVIEW: http://review.gluster.org/11026 (libglusterfs: Copy d_len and dict as well into dst dirent) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 3 Anand Avati 2015-06-02 13:52:38 UTC
REVIEW: http://review.gluster.org/11026 (libglusterfs: Copy d_len and dict as well into dst dirent) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 4 Anand Avati 2015-06-03 03:46:22 UTC
COMMIT: http://review.gluster.org/11026 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit e1d9895ba6f7763ba4602094f6516a6ab4a054d4
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Jun 1 11:55:29 2015 +0530

    libglusterfs: Copy d_len and dict as well into dst dirent
    
    Also, added memory allocation failure checks in light of the
    comments received @
    http://review.gluster.org/#/c/10809/2/libglusterfs/src/gf-dirent.c, and
    http://review.gluster.org/#/c/10809/1/xlators/features/shard/src/shard.c
    
    Change-Id: Ie4092218545c8f4f8a0e6cc1fec6ba37bbbf2620
    BUG: 1226551
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/11026
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 5 Nagaprasad Sathyanarayana 2015-10-25 14:54:28 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 6 Niels de Vos 2016-06-16 13:06:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.