Bug 122659 - mounting a filesystem occasionally hangs
mounting a filesystem occasionally hangs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 13:50 EDT by Eric Sandeen
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-06 18:05:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2004-05-06 13:50:58 EDT
Description of problem:
mount occasionally hangs

saw this while running through xfsqa; certainly does not happen
every time but i've seen it about 3-4 times in the course of
running a 90-test qa suite 4-5 times.

Anyway - 

Mounting an xfs filesystem:

30181 pts/0    R      1:16 /bin/mount -t xfs -ologbsize=256k /dev/sda2
/mnt/sda2

never returns.  I shoehorned kdb into fc2; it doesnt' seem very
happy but here's what I get out of it:

[0]kdb> btp 30181
Stack traceback for pid 30181
0x039a9930    30181    29982  1    1   R  0x039a9bc0  mount
ESP        EIP        Function (args)
0x05aa3f3c 0x02153fa7 rw_vm+0x18f (0x0, 0x1000, 0x4bd1000)
                               kernel 0x2153e18 0x2154103
0x05aa3f74 0x02154443 get_user_size+0x2e (0x5aa3fa8, 0x5aa3fc4,
0xc0ed0000)
                               kernel 0x2154415 0x215446a
0x05aa3f88 0x02172d76 copy_mount_options+0x4d
                               kernel 0x2172d29 0x2172dc0
0x05aa3fa0 0x0217326c sys_mount+0x13
                               kernel 0x2173259 0x21733b9

[0]kdb> md 0x4bd1000
0x04bd1000 00736678 00000000 00000000 00000021   .sfx...........!
0x04bd1010 62676f6c 657a6973 3635323d 6f6c2c6b   bgolezis652=ol,k
0x04bd1020 69736267 323d657a 006b3635 00000021   isbg2=ez.k65...!
0x04bd1030 62676f6c 657a6973 3635323d 6f6c006b   bgolezis652=ol.k
0x04bd1040 69736267 323d657a 006b3635 00000021   isbg2=ez.k65...!
0x04bd1050 62676f6c 657a6973 3635323d 6f6c2c6b   bgolezis652=ol,k
0x04bd1060 69736267 323d657a 006b3635 00020039   isbg2=ez.k65...9
0x04bd1070 00000000 00000000 00000000 00000000   ................

so although this is an xfs mount it's not in xfs code that things are
stuck...

any suggestions for further debugging this w/o kdb would be
appreciated; sysrq-t doesnt' give me any useful info since the 
process is running and no stack is generated.
Comment 1 Dave Jones 2004-11-29 05:04:05 EST
did this get fixed in the latest update kernel?
Comment 2 Eric Sandeen 2004-12-06 18:05:34 EST
using 2.6.9-1.681_FC3smp with the xfs qa test suite I see a few other errors,
but not this one anymore, so looks like this bug can go away.

Closing with NOTABUG (anymore) because the drop down list doesn't give me
any other options.  :)

Note You need to log in before you can comment on or make changes to this bug.