Bug 1226659 - double-clicking empty space on tab bar no longer opens new tab in Fedora 21 and 22
Summary: double-clicking empty space on tab bar no longer opens new tab in Fedora 21 a...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-31 14:10 UTC by April
Modified: 2016-09-01 08:51 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-12 14:42:51 UTC


Attachments (Terms of Use)
cursor changes to grab hand when click (114.60 KB, image/png)
2015-06-24 14:12 UTC, April
no flags Details

Description April 2015-05-31 14:10:15 UTC
Description of problem:
In Firefox 38.0 on Fedora 20, double-clicking on an empty area of the tab bar opens a new tab. This no longer works in Fedora 21 or 22, which have Firefox compiled against GTK3 instead of GTK2.

Version-Release number of selected component (if applicable):
38.0, in Fedora 22 and 21 (not in Fedora 20)

How reproducible:
100%

Comment 1 Martin Stransky 2015-06-01 05:28:32 UTC
Fedora 21 is Gtk2.

Comment 2 April 2015-06-01 12:09:17 UTC
Sorry, I realized that but forgot to correct this bug. Since it is the same version of Firefox in F20 through F22, I assumed this was yet another GTK3 issue, but I guess there's some other difference that started in F21....

Comment 3 Jan Horak 2015-06-22 12:56:24 UTC
Hm, I can't reproduce this one on Fedora 22. Could you try to check with fresh profile and/or in safe mode (by firefox -safe-mode)? Thank you.

Comment 4 April 2015-06-24 14:12:17 UTC
Same result in fresh profile and in safe mode.

If it's relevant, I'm using the Mate Desktop Environment.

I notice that the cursor changes to the grabbing hand while double-clicking. If I press down and hold the mouse button, it remains the hand and if I then move the mouse the window is restored (unmaximized) and drags around the screen. The issue seems to be that gtk3 considers this to be a draggable area of the window. I will attach a screen capture showing the cursor when I click and hold ...

Comment 5 April 2015-06-24 14:12:50 UTC
Created attachment 1042768 [details]
cursor changes to grab hand when click

Comment 6 Martin Stransky 2015-06-30 11:50:05 UTC
I can't reproduce, Fedora 22, MATE.

Comment 7 April 2015-06-30 15:39:42 UTC
Just checking that you each understand that I am not talking about clicking on the new tab button, but instead I am talking about double-clicking on an empty area of the tab bar.

I can reproduce this issue 100% of the time in the F22 Mate Spin Live CD, without any changes to any settings. It is very confusing if you are not able to reproduce under those conditions.

Comment 8 Jan Horak 2015-07-01 06:47:57 UTC
Surprisingly double click doesn't work if you don't use Persona theme. I'm able to reproduce it now.

Comment 9 Christian Stadelmann 2015-07-12 21:33:57 UTC
I can reproduce this with
1. a clean, fresh profile (38.0.x and 39.0.x)
2. a long-used profile (38.0.x and 39.0.x)
3. tor browser 5.0a3 (based on Mozilla Firefox 38.1.0)
under GNOME.

I think this has been so for a while.

Comment 10 Jan Horak 2015-11-12 14:42:51 UTC
Finally able to reproduce with Bluebird theme. It's related to theme and it depends on -GtkWidget-window-dragging: true;

Workaround is to put:

.menubar {
  -GtkWidget-window-dragging: false;
}
into: ~/.config/gtk-3.0/gtk.css

We're going to track this issue on upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1224206

Comment 11 Jan Horak 2016-09-01 08:51:36 UTC
Updated workaround:

menubar,
.menubar {
  -GtkWidget-window-dragging: false;
}


Note You need to log in before you can comment on or make changes to this bug.