Bug 1226670 - [HE] Failed to add second host | Failed to execute stage 'Setup validation': [Errno 2] No such file or directory: '/rhev/data-center/mnt/10.35.160.108:_RHEV_nsednev__HE__3__5/70c68239-5fd3-48fc-9eb9-4d7bdf1ef773/ha_agent/hosted-engine.metadata'
Summary: [HE] Failed to add second host | Failed to execute stage 'Setup validation': ...
Keywords:
Status: CLOSED DUPLICATE of bug 1215967
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.6.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.6.0
Assignee: Sandro Bonazzola
QA Contact: Nikolai Sednev
URL:
Whiteboard: integration
Depends On:
Blocks: 1159314 1216172 1221148
TreeView+ depends on / blocked
 
Reported: 2015-05-31 16:41 UTC by Nikolai Sednev
Modified: 2015-06-08 08:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-08 08:06:52 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
logs from host blue (5.77 MB, application/x-gzip)
2015-05-31 16:41 UTC, Nikolai Sednev
no flags Details
brownvdsd.tar.gz (9.44 MB, application/x-gzip)
2015-05-31 16:49 UTC, Nikolai Sednev
no flags Details

Description Nikolai Sednev 2015-05-31 16:41:19 UTC
Created attachment 1032892 [details]
logs from host blue

Description of problem:

[root@blue-vdsc ~]# hosted-engine --deploy                                                                                                                 
[ INFO  ] Stage: Initializing                                                                                                                              
[ INFO  ] Generating a temporary VNC password.                                                                                                             
[ INFO  ] Stage: Environment setup                                                                                                                         
          Continuing will configure this host for serving as hypervisor and create a VM where you have to install oVirt Engine afterwards.                 
          Are you sure you want to continue? (Yes, No)[Yes]:                                                                                               
          Configuration files: []                                                                                                                          
          Log file: /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20150531191910-uh66l4.log                                                 
          Version: otopi-1.4.0_master (otopi-1.4.0-0.0.master.20150423125505.git08ea44e.el7)                                                               
          It has been detected that this program is executed through an SSH connection without using screen.                                               
          Continuing with the installation may lead to broken installation if the network connection fails.                                                
          It is highly recommended to abort the installation and run it inside a screen session using command "screen".                                    
          Do you want to continue anyway? (Yes, No)[No]: yes                                                                                               
[ INFO  ] Hardware supports virtualization                                                                                                                 
[ INFO  ] Stage: Environment packages setup                                                                                                                
[ INFO  ] Stage: Programs detection                                                                                                                        
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization

          --== STORAGE CONFIGURATION ==--

          During customization use CTRL-D to abort.
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs3, nfs4)[nfs3]:
          Please specify the full shared storage connection path to use (example: host:/path): 10.35.160.108:/RHEV/nsednev_HE_3_5
          The specified storage location already contains a data domain. Is this an additional host setup (Yes, No)[Yes]?
[ INFO  ] Installing on additional host
          Please specify the Host ID [Must be integer, default: 2]:
          Local storage datacenter name is an internal name
          and currently will not be shown in engine's admin UI.
          Please enter local datacenter name [hosted_datacenter]:

          --== SYSTEM CONFIGURATION ==--

[WARNING] A configuration file must be supplied to deploy Hosted Engine on an additional host.
          The answer file may be fetched from the first host using scp.
          If you do not want to download it automatically you can abort the setup answering no to the following question.
          Do you want to scp the answer file from the first host? (Yes, No)[Yes]:
          Please provide the FQDN or IP of the first host: brown-vdsd.qa.lab.tlv.redhat.com
          Enter 'root' user password for host brown-vdsd.qa.lab.tlv.redhat.com:
[ INFO  ] Answer file successfully downloaded

          --== NETWORK CONFIGURATION ==--

          Please indicate a nic to set ovirtmgmt bridge on: (enp4s0, enp6s0) [enp4s0]:
[ INFO  ] Additional host deployment, firewall manager is 'iptables'
          The following CPU types are supported by this host:
                 - model_Conroe: Intel Conroe Family

          --== HOSTED ENGINE CONFIGURATION ==--

          Enter the name which will be used to identify this host inside the Administrator Portal [hosted_engine_2]:
          Enter 'admin@internal' user password that will be used for accessing the Administrator Portal:
          Confirm 'admin@internal' user password:
[ INFO  ] Stage: Setup validation
[ ERROR ] Failed to execute stage 'Setup validation': [Errno 2] No such file or directory: '/rhev/data-center/mnt/10.35.160.108:_RHEV_nsednev__HE__3__5/70c68239-5fd3-48fc-9eb9-4d7bdf1ef773/ha_agent/hosted-engine.metadata'
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20150531192010.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[root@blue-vdsc ~]#

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Deploy HE on first host, define within the engine different admin password than within the host deployment, so when engine installation is finished, setup deployment script on host will ask to provide another password, as it will fail to communicate with the engine.
2.Now you have engine running over first host.
3.Add second host to HE via hosted-engine --deploy script.

Actual results:
Deployment fails to complete.

Expected results:
Deployment on second host should succeed.

Additional info:
Logs from second host (blue) and from first host (brown). 
Installation performed on clean environment of REHL7.1 on hosts and RHEL6.6 on engine.

Comment 1 Nikolai Sednev 2015-05-31 16:49:49 UTC
Created attachment 1032893 [details]
brownvdsd.tar.gz

Comment 2 Simone Tiraboschi 2015-06-08 08:06:52 UTC

*** This bug has been marked as a duplicate of bug 1215967 ***


Note You need to log in before you can comment on or make changes to this bug.