Bug 1226809 - Overflow in malloc size calculation in VMDK driver
Summary: Overflow in malloc size calculation in VMDK driver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Fam Zheng
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1217351
Blocks: 1218823
TreeView+ depends on / blocked
 
Reported: 2015-06-01 07:36 UTC by Fam Zheng
Modified: 2015-12-04 16:43 UTC (History)
9 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-3.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1217351
Environment:
Last Closed: 2015-12-04 16:43:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Comment 2 Miroslav Rezanina 2015-06-19 11:09:06 UTC
Fix included in qemu-kvm-rhev-2.3.0-3.el7

Comment 3 Qian Guo 2015-07-01 08:04:16 UTC
Reproduced this bug with qemu-kvm-rhev-2.1.2-23.el7.x86_64
steps:

# qemu-img info afl6.img 

result:
# qemu-img info afl6.img 
qemu-img: Could not open 'afl6.img': Could not open 'afl6.img': Cannot allocate memory

So this bug is reproduced.


Verified this bug with qemu-kvm-rhev-2.3.0-6.el7.x86_64

result:
# qemu-img info afl6.img 
qemu-img: Could not open 'afl6.img': Could not read l1 table from extent 'afl6.img': Invalid argument

No overflow occurs, just report it invalid,  so this bug is fixed.

Comment 7 errata-xmlrpc 2015-12-04 16:43:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.