Bug 1226853 - Volume start fails when glusterfs is source compiled with GCC v5.1.1
Summary: Volume start fails when glusterfs is source compiled with GCC v5.1.1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.7.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1226307
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-01 09:55 UTC by Anoop C S
Modified: 2015-06-02 08:24 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1226307
Environment:
Last Closed: 2015-06-02 08:04:22 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
Warnings during compilation (9.14 KB, text/plain)
2015-06-01 09:55 UTC, Anoop C S
no flags Details

Description Anoop C S 2015-06-01 09:55:14 UTC
Created attachment 1033240 [details]
Warnings during compilation

+++ This bug was initially created as a clone of Bug #1226307 +++

Description of problem:
When GlusterFS [master] is compiled and built on a fedora 22 machine with GCC v5.1.1, volume start fails with the following error in brick logs

[2015-05-28 07:12:42.176108] I [event-epoll.c:629:event_dispatch_epoll_worker] 0-epoll: Started thread with index 1
[2015-05-28 07:12:42.178705] W [xlator.c:192:xlator_dynload] 0-xlator: /usr/local/lib/glusterfs/3.8dev/xlator/features/changelog.so: undefined symbol: changelog_select_event
[2015-05-28 07:12:42.178721] E [graph.y:212:volume_type] 0-parser: Volume 'patchy-changelog', line 30: type 'features/changelog' is not valid or not found on this machine
[2015-05-28 07:12:42.178733] E [graph.y:321:volume_end] 0-parser: "type" not specified for volume patchy-changelog
[2015-05-28 07:12:42.178850] E [MSGID: 100026] [glusterfsd.c:2149:glusterfs_process_volfp] 0-: failed to construct the graph
[2015-05-28 07:12:42.178974] W [glusterfsd.c:1219:cleanup_and_exit] (--> 0-: received signum (0), shutting down

Version-Release number of selected component (if applicable):

GlusterFS (master) on fedora22 with GCC v5.1.1

How reproducible:
Always

Steps to Reproduce:
1. git clone master from review.gluster.org
2. Compile and install
3. Create a simple distributed volume
4. Start the volume

Actual results:
Volume start failed.

Expected results:
Volume start should be successful

Additional info:

--- Additional comment from Anand Avati on 2015-05-29 08:18:08 EDT ---

REVIEW: http://review.gluster.org/11004 (features/changelog: Remove inline keyword to avoid warnings (gcc v5.1.1)) posted (#1) for review on master by Anoop C S (achiraya@redhat.com)

--- Additional comment from Anoop C S on 2015-05-29 08:23:54 EDT ---



--- Additional comment from Anand Avati on 2015-05-29 11:09:43 EDT ---

REVIEW: http://review.gluster.org/11004 (features/changelog: Remove inline keyword to avoid warnings (gcc v5.1.1)) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-01 04:56:31 EDT ---

COMMIT: http://review.gluster.org/11004 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit eeb356584897ff778ffcbacff1c71d35d277b726
Author: Anoop C S <achiraya@redhat.com>
Date:   Fri May 29 16:33:09 2015 +0530

    features/changelog: Remove inline keyword to avoid warnings (gcc v5.1.1)
    
    When compiled with gcc5, following warnings were displayed
    and volume start failed:
    
    changelog-helpers.h:499:1: warning: inline function 'changelog_dispatch_event'
    declared but never defined
     changelog_dispatch_event (xlator_t *, changelog_priv_t *, changelog_event_t *);
    
    gf-changelog-journal-handler.c:692:17: warning: 'list_add_tail' is static but
    used in inline function 'gf_changelog_queue_journal' which is not static
                     list_add_tail (&entry->list, &jnl_proc->entries);
    
    Fix is to remove the keyword from function prototype and
    definitions.
    
    Change-Id: I188b35b7ca087a94d7a48a052b05a6d845e3b74b
    BUG: 1226307
    Signed-off-by: Anoop C S <achiraya@redhat.com>
    Reviewed-on: http://review.gluster.org/11004
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>

Comment 1 Anand Avati 2015-06-01 10:03:11 UTC
REVIEW: http://review.gluster.org/11030 (features/changelog: Remove inline keyword to avoid warnings (gcc v5.1.1)) posted (#1) for review on release-3.7 by Anoop C S (achiraya@redhat.com)

Comment 2 Anand Avati 2015-06-01 10:31:13 UTC
REVIEW: http://review.gluster.org/11030 (features/changelog: Remove inline keyword to avoid warnings (gcc v5.1.1)) posted (#2) for review on release-3.7 by Anoop C S (achiraya@redhat.com)

Comment 3 Anand Avati 2015-06-01 13:56:07 UTC
COMMIT: http://review.gluster.org/11030 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit f266dc6be5b401a7a813adc958d978eb9207cd63
Author: Anoop C S <achiraya@redhat.com>
Date:   Fri May 29 16:33:09 2015 +0530

    features/changelog: Remove inline keyword to avoid warnings (gcc v5.1.1)
    
            Backport of http://review.gluster.org/11004
    
    When compiled with gcc5, following warnings were displayed
    and volume start failed:
    
    changelog-helpers.h:499:1: warning: inline function 'changelog_dispatch_event'
    declared but never defined
     changelog_dispatch_event (xlator_t *, changelog_priv_t *, changelog_event_t *);
    
    gf-changelog-journal-handler.c:692:17: warning: 'list_add_tail' is static but
    used in inline function 'gf_changelog_queue_journal' which is not static
                     list_add_tail (&entry->list, &jnl_proc->entries);
    
    Fix is to remove the keyword from function prototype and
    definitions.
    
    Change-Id: I188b35b7ca087a94d7a48a052b05a6d845e3b74b
    BUG: 1226853
    Signed-off-by: Anoop C S <achiraya@redhat.com>
    Reviewed-on: http://review.gluster.org/11030
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>

Comment 4 Niels de Vos 2015-06-02 08:04:22 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.