Bug 1226902 - bitrot: scrubber is crashing while user set any scrubber tunable value.
Summary: bitrot: scrubber is crashing while user set any scrubber tunable value.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: bitrot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Satish Mohan
QA Contact:
bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-01 12:14 UTC by Gaurav Kumar Garg
Modified: 2016-06-16 13:07 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 13:07:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Gaurav Kumar Garg 2015-06-01 12:14:12 UTC
Description of problem:

as per http://build.gluster.org/job/rackspace-regression-2GB-triggered/9925/consoleFull   regression test, scrubber daemon is crashing and its creating a core file. This is because of before timer initialization, scrubber  reconfiguring the timer. 


Version-Release number of selected component (if applicable):
main line.

How reproducible:
1/10  (very rare)

Steps to Reproduce:
Its a race condition very rare to reproduce. 

Actual results:
scrubber daemon is crashing.

Expected results:
scrubber daemon should not crash.

Comment 1 Anand Avati 2015-06-01 12:24:32 UTC
REVIEW: http://review.gluster.org/11033 (bitrot/tests: sleep for some time so that timer can initialize) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 2 Anand Avati 2015-06-02 03:14:51 UTC
REVIEW: http://review.gluster.org/11033 (tests/bitrot: Induce delay before invoking bitrot subcommands) posted (#2) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 3 Anand Avati 2015-06-02 03:50:48 UTC
REVIEW: http://review.gluster.org/11033 (tests/bitrot: Induce delay before invoking bitrot subcommands) posted (#3) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 4 Gaurav Kumar Garg 2015-12-10 07:34:00 UTC
patch got merged so making status of the bug in modified state

Comment 7 Niels de Vos 2016-06-16 13:07:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.