Bug 122694 - Init does not start services
Init does not start services
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 21:17 EDT by Need Real Name
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 15:03:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-05-06 21:17:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
I installed Fedora Core 1 on a Fujitsu Lifebook (N3010) - dual boot
with WinXP, using GRUB - got the latest updates with up2date,
configured the system to my likings, and it worked fine... for a
couple of days. 
After a (possibly unrelated) problem with rsync, I halted the machine.
The next time I rebooted (to initdefault 3), I get the messages 
"INIT: version 2.85 booting"
"INIT: Entering runlevel: 3"
and then straightaway
"Fedora Core release 1 (Yarrow)"
"Kernel 2.4.22-1.2188.nptl on an i686"
"(none) login:"

i.e. no services are started at all, but no obvious error messages are
generated either. Needless to say I cannot login. 

Using the Fedora CD-rom to start Linux in rescue mode, all file
systems can be mounted, but when doing a "chroot /mnt/sysimage", it
tells me "Segmentation fault".

It is also not possible to start a single user mode with a minimal
shell (init=/bin/bash) -- the system then presents me with a line
"INIT: no more processes left in this runlevel" and does nothing more. 

Control-Alt-Delete in this state yields a 
"shutdown: warning: cannot open /var/run/shutdown.pid"
followed by again a "no more processes left in this runlevel" message
without actually shutting down. 

Exactly the same thing happens independent of the kernel I choose (I
have 2.4.22-1.2188 and 2.4.22-1.2155 installed). 

I thought it might be that the root filesystem is not properly
mounted, but I then cannot understand why changes made in the
/etc/inittab file made using the rescue mode do change the behavior
somehwat. Moreover, with the rescue mode I seem to be able to properly
mount all filesystems. It just looks as if the /etc/rc.d/rc.sysinit
script is not executed for some reason. I also checked to make sure
there are actually services to start in the rc.d directories, and
those look fine. 

Version-Release number of selected component (if applicable):
initscripts-7.42.2-1


How reproducible:
Always

Steps to Reproduce:
1. Start the machine
2. Boot Linux with GRUB
3. Watch how it doesn't really work. 
    

Actual Results:  See Description

Expected Results:  The same sort of result as I had before : nicely
booting and running all the services specified in the rc.d directories. 

Additional info:
Here's my /etc/fstab :
LABEL=/      /         ext3   defaults       1 1
none         /dev/pts  devpts gid=5,mode=620 0 0
none         /proc     proc   defaults       0 0
none         /dev/shm  tmpfs  defaults       0 0
LABEL=/tmp   /tmp      ext3   defaults       1 2
LABEL=/usr   /usr      ext3   defaults       1 2
LABEL=/var   /var      ext3   defaults       1 2
/dev/hda4    swap      swap   defaults       0 0
Comment 1 Bill Nottingham 2004-05-21 14:14:53 EDT
What does 'rpm -V initscripts' say?
Comment 2 Need Real Name 2004-05-21 15:01:15 EDT
Says nothing anymore. In the meantime, I installed Fedora Core 2
instead and that seems to be working fine. When I first tried to do a
reinstall with Core 1, there were quite some issues when arriving at
the partition part. Disk Druid apparently saw a lot of "Free Space"
segments, of 0 MB inbetween each partition. Not possible to change
anything about that though, so reformatted the disk, and Core 2 had no
problems with the partitioning. 
Comment 3 Bill Nottingham 2004-05-21 15:03:09 EDT
Hm, OK. Please re-open if it comes back.

Note You need to log in before you can comment on or make changes to this bug.