Bug 1227003 - Invalid credential MSG=Hosts do not match
Summary: Invalid credential MSG=Hosts do not match
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: torque
Version: el6
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: David Brown
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-01 16:07 UTC by arif
Modified: 2015-07-16 01:48 UTC (History)
4 users (show)

Fixed In Version: torque-4.2.10-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-13 19:07:09 UTC


Attachments (Terms of Use)

Description arif 2015-06-01 16:07:22 UTC
Description of problem:

Whenever we run any of the clients we get the error:

   Invalid credential MSG=Hosts do not match

The 'fix' is to specify  the server host name $(hostname).

However we have an existing user and code base and this is stopping our transition to the new packages.

Version-Release number of selected component (if applicable):

torque-server-4.2.10-3.el6.x86_64

How reproducible:

100% on a bunch of systems.

Steps to Reproduce:
1. update to torque-* version 4.2.10-3 or higher
2. start pbs_server
3. qmgr -c 'p s'

Actual results:

qmgr obj= svr=default: Invalid credential MSG=Hosts do not match

Expected results:

server configuration listing

Additional info:

Specifying the local host name works
  qmgr -c 'p s' $(hostname)

The contents of /etc/torque/server_name 
localhost

The result is the same even if we put the host name in /etc/torque/server_name 

/etc/hosts contains just

127.0.0.1       localhost       loghost localhost.localdomain
::1             localhost6.localdomain6 localhost6

DNS is configured correctly.

Comment 1 arif 2015-06-19 19:53:57 UTC
For the record....

The issue is caused by the new trqauthd daemon.

This daemon starts by reading the contents of /etc/torque/server_name. If it is set to localhost when the daemon starts but the FQDN is something else (as it usually is) then any authentication fails. Setting the server_name file and restarting trqauthd fixes the issue.

Comment 2 Fedora Update System 2015-06-30 06:24:29 UTC
torque-4.2.10-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/torque-4.2.10-5.fc22

Comment 3 Fedora Update System 2015-06-30 06:25:40 UTC
torque-4.2.10-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/torque-4.2.10-5.fc21

Comment 4 Fedora Update System 2015-06-30 06:28:04 UTC
torque-4.2.10-5.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/torque-4.2.10-5.el7

Comment 5 Fedora Update System 2015-06-30 06:28:46 UTC
torque-4.2.10-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/torque-4.2.10-5.el6

Comment 6 Fedora Update System 2015-06-30 06:29:27 UTC
torque-4.2.10-5.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/torque-4.2.10-5.el5

Comment 7 Fedora Update System 2015-06-30 20:19:24 UTC
Package torque-4.2.10-5.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing torque-4.2.10-5.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10967/torque-4.2.10-5.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-07-13 19:07:09 UTC
torque-4.2.10-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-07-14 15:36:27 UTC
torque-4.2.10-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-07-16 01:47:20 UTC
torque-4.2.10-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-07-16 01:47:35 UTC
torque-4.2.10-5.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-07-16 01:48:02 UTC
torque-4.2.10-5.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.