Bug 1227013 - Broken nodes links in undercloud Horizon
Summary: Broken nodes links in undercloud Horizon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar-ui
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ga
: Director
Assignee: Jiri Tomasek
QA Contact: Marius Cornea
URL:
Whiteboard:
: 1229367 1234387 1235279 1239292 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-01 16:54 UTC by Marius Cornea
Modified: 2015-08-05 13:52 UTC (History)
11 users (show)

Fixed In Version: openstack-tuskar-ui-0.3.0-9.el7ost
Doc Type: Bug Fix
Doc Text:
The node detail URL name was specified incorrectly and rendered incorrectly. This fix corrects the node detail URL name. Now the node detail link renders correctly, which allows access to the node detail page.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:52:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
Tuskar nodes links (242.06 KB, image/png)
2015-07-13 19:15 UTC, Marius Cornea
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 189330 None None None Never
OpenStack gerrit 195605 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Marius Cornea 2015-06-01 16:54:15 UTC
Description of problem:
Al the nodes links in undercloud Horizon point to horizon:infrastructure:nodes:detail.

Version-Release number of selected component (if applicable):
openstack-dashboard-2015.1.0-8.el7ost.noarch
openstack-dashboard-theme-2015.1.0-8.el7ost.noarch
instack-undercloud-2.1.0-3.el7ost.noarch
instack-0.0.6-5.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install undercloud.
2. Register nodes
3. Log in to Horizon via UI
4. Click on Nodes tab
5. Go to 'All' subtab
6. Click on any on the nodes

Actual results:
Nodes link to 'horizon:infrastructure:nodes:detail'

Expected results:
The node page should load. 

Additional info:

Comment 4 Ana Krivokapic 2015-06-18 14:14:11 UTC
*** Bug 1229367 has been marked as a duplicate of this bug. ***

Comment 5 Jiri Tomasek 2015-06-23 12:17:47 UTC
Fixed by https://review.openstack.org/#/c/189330/

Comment 6 Jiri Tomasek 2015-06-24 12:00:34 UTC
*** Bug 1234387 has been marked as a duplicate of this bug. ***

Comment 7 Jiri Tomasek 2015-06-24 12:01:13 UTC
Problem still occurs, although just downstream, will do more investigation.

Comment 8 Ana Krivokapic 2015-06-24 13:42:22 UTC
*** Bug 1235279 has been marked as a duplicate of this bug. ***

Comment 9 Ana Krivokapic 2015-07-05 15:04:41 UTC
*** Bug 1239292 has been marked as a duplicate of this bug. ***

Comment 10 Ana Krivokapic 2015-07-06 14:04:31 UTC
Both changes have been merged both upstream and downstream.

Comment 12 Marius Cornea 2015-07-13 19:15:09 UTC
Created attachment 1051493 [details]
Tuskar nodes links

Attaching screenshot with the nodes links.

Comment 14 errata-xmlrpc 2015-08-05 13:52:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.