Bug 122703 - gnome-font-properties not working properly for gtk apps run in kde
gnome-font-properties not working properly for gtk apps run in kde
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-07 03:18 EDT by Mary Ellen Foster
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 05:32:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of system-config-network before running gnome-font-properties (15.30 KB, image/png)
2004-05-07 03:19 EDT, Mary Ellen Foster
no flags Details
Screenshot of system-config-network after running gnome-font-properties (13.29 KB, image/png)
2004-05-07 03:19 EDT, Mary Ellen Foster
no flags Details
gnome starter script to initialize the fonts within kde (61 bytes, text/plain)
2005-01-25 07:14 EST, Thomas Hartwig
no flags Details

  None (edit)
Description Mary Ellen Foster 2004-05-07 03:18:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040404 Firefox/0.8

Description of problem:
I use kde as my desktop, but I still run various gtk-based
applications -- not least, the system-config-* tools. I wanted the
font in the gtk apps to be the same as my kde font, so I used
gnome-font-properties to set it. However, this doesn't seem to "stick"
under kde; every time I start kde, apps come up with too-big fonts
until I run gnome-font-properties again explicitly.

Note that gnome-font-properties comes up with the proper defaults
selected, but before I run it, all my gtk apps have what looks like
the correct font, just too big. I'll attach screenshots.

Also, if I choose gnome as my desktop environment, the font is
correct; it's just when I log in using kde and run gtk apps that the
font starts out too big.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use gnome-font-properties to choose Bitstream Vera Sans 8
2. Log out
3. Log in using kde
4. Start a gtk app (e.g., system-config-network)
5. The font looks like Bitstream Vera Sans 9 or 10 (see before.png)
6. Run gnome-font-properties -- don't change anything, just run it
   (it comes up with the correct defaults selected) and close it
7. Run system-config-network again; now the font is the correct
   8-point size (after.png)

Actual Results:  The font isn't the right size until I've run
gnome-font-properties

Expected Results:  The font should be the right size!
Comment 1 Mary Ellen Foster 2004-05-07 03:19:12 EDT
Created attachment 100065 [details]
Screenshot of system-config-network before running gnome-font-properties
Comment 2 Mary Ellen Foster 2004-05-07 03:19:44 EDT
Created attachment 100066 [details]
Screenshot of system-config-network after running gnome-font-properties
Comment 3 Mary Ellen Foster 2004-05-07 05:32:40 EDT
Okay, never mind; I looked into this a bit more and it looks like I 
need to run gnome-settings-daemon as part of my X startup in KDE, 
and then the settings will propagate to any GTK apps I start up. I 
guess a side effect of running gnome-font-properties in my above 
procedure was that *it* started gnome-settings-daemon, which then 
made other stuff work properly. 
 
Would be nice if this would happen automatically ... 
Comment 4 Thomas Hartwig 2005-01-25 07:01:10 EST
I can not see why this is not a bug in the default distribution. I
think this should really be fixed someday.
I can confirm this behaviour for final Core 2 and Core 3. I would
highly encourage to reopen this bug.
Comment 5 Thomas Hartwig 2005-01-25 07:14:24 EST
Created attachment 110189 [details]
gnome starter script to initialize the fonts within kde

This little script starts and kills gnome-font-properties to initialize the
fonts for gtk applications. Put this in ~/.kde/Autostart if you like.

Note You need to log in before you can comment on or make changes to this bug.