Bug 122708 - X.org doesn't work out of box with exec-shield
Summary: X.org doesn't work out of box with exec-shield
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-05-07 10:54 UTC by Mike A. Harris
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 6.7.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 11:58:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2004-05-07 10:54:52 UTC
The assembler files in stock X and Mesa, do not use GNU stacks on
Linux systems, which means they will not work properly with
exec-shield.  I fixed this problem in XFree86 4.3.0 by writing the
XFree86-4.3.0-redhat-exec-shield-GNU-stack.patch patch, which
patched every assembler file to include .note.GNU-stack sections.

While that is considered a cleaner solution, my patch was non-portable
to non-GNU systems, so unsuitable for upstream acceptance as-was.  The
patch was disabled for X.org due to failure to apply, and didn't get
ported forward yet.

Nobody's noticed that X doesn't work with exec-shield aparently until
now.  ;o)

Jakub suggested an alternate solution of passing the assembler
"-Wa,--noexecstack", which is a simpler workaround for now instead
of porting patches each release or spending time to make sure the
patch works on every OS in existance.

Comment 1 Mike A. Harris 2004-05-07 10:58:34 UTC
Modified AsCmd as follows in 6.7.0-2

-#define AsCmd               CcCmd -c -x assembler
+#define AsCmd               CcCmd -c -x assembler -Wa,--noexecstack


Note You need to log in before you can comment on or make changes to this bug.