Bug 122711 - NFS - Cannot mount
NFS - Cannot mount
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-07 07:24 EDT by Kyrre Ness Sjøbæk
Modified: 2015-01-04 17:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 01:27:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2004-05-07 07:24:02 EDT
Description of problem:
I am trying to mount /home from my Debian NFS server, but keep 
getting the error message "mount to NFS server `172.26.101.48` 
failed: server is down". But the server is obiviousiy up, as I am 
writing this from a thin client whose server mounts /home from the 
same spot...

The server is up, I am able to ping it, ssh to it, and rpcinfo -p 
shows theese:
portmapper (ver 2, port 111, tcp and udp), rquotad (vers. 1 and 2, 
tcp and udp, port 830 and 833), status (ver. 1, udp and tcp, port 
32768), nfs (version 2, tcp/udp, port 2049, mountd (version 1 and 2, 
tcp/udp, port 955 and 958)

I have also tried to re-export it from the thin-client server I 
mentioned, but with no luck (also tried insecure):
mount: 172.26.100.253:/home failed, reason given by server: 
Permission denied

At home i have a FC2-t3 test-computer which mounts a NFS export on my 
desktop (noauto, users). That works great, so NFS is not totaly 
broken.

Version-Release number of selected component (if applicable):
As suplied with fedora core 2 test 3

How reproducible:
Try to mount an nfs export

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Error message

Expected results:
Get mounted

Additional info:
As I said, it works at home. Also seen several mailing list postings 
by searching the web for "mount to NFS server" "failed: server is 
down" (google).

And nfs does not show up in /proc/filesystems
normal? (nothing is mounted so maybe if its a loadable module it is 
normal?)
Comment 1 Steve Dickson 2004-05-07 10:38:44 EDT
Use the '-v' option on the mount command... It will show
the RPC error (if any) that is being returned. 
Comment 2 Dan Morrill 2004-05-09 02:16:28 EDT
This might be a duplicate of 12294.  Is the original poster using 
autofs to mount /home, or is it an fstab mount? 
Comment 3 Kyrre Ness Sjøbæk 2004-05-09 15:47:09 EDT
I am using fstab, and then using mount -a to mount the stuff.

Pretty shure (at least 99%) that i am using the correct options in
fstab - the line looks something like

172.26.101.48:/home /home nfs defaults 0 0

(at least it that what i think it should look like - but I am not on
the site rigth now, and won't be until friday. I've asked someone who
should be on site tomorow to take a look, but i do no know if it will
be done.)
Comment 4 Steve Dickson 2004-05-10 07:58:22 EDT
in the original comment rpcinfo -p is only showing
nfs (version 2, tcp/udp, port 2049). Is this truly the
case or just a typo?

If so does mount -o vers=2 work?
Comment 5 Kyrre Ness Sjøbæk 2004-05-14 14:29:12 EDT
no, it was no typo :D

Works now, but why didn't it detect it automatically?
Comment 6 Steve Dickson 2004-10-14 17:00:46 EDT
Is this still an issue with more recent FC kernels and autofs rpms?
Comment 7 Kyrre Ness Sjøbæk 2004-10-15 13:52:03 EDT
this is an fstab mount. I still have to specify -o vers=2 when
mounting manually.

But something changed during the upgrade of nfs-utils earlier this
week - suddenly stat() became *very* slow. I am going to open another
bug at that one.
Comment 8 Dave Jones 2004-11-29 05:05:39 EST
how are things with the 2.6.9 based errata kernel ?
Comment 9 Kyrre Ness Sjøbæk 2004-11-29 10:20:33 EST
The vers=2 stuff or the stat (that was LDAP... I don't know what was wrong, it
migth have been the server... "Fixed" it by enabeling nscd.. But we are almost
finished swithching out that old crap box with a new server - debian sarge - and
it don't have any problems with nfs v3...)

Note You need to log in before you can comment on or make changes to this bug.