Fedora Account System
Red Hat Associate
Red Hat Customer
Created attachment 1033548 [details] virt-manager --debug output Description of problem: Virt-Manager fails with Error polling connection after upgrade Virsh does work flawless and can connect to the remote libvirtd instance System: archlinux Version-Release number of selected component (if applicable): virt-manager version: 1.2.0 this is a regression of 1.2 - it worked under 1.1 How reproducible: Steps to Reproduce: 1. open virt-manager --debug 2. see the error message (below) 3. connection is closed Actual results: does not connect and quits the connection Expected results: work as expected (allow me to start/stop/manage vms) Additional info: summary=Error polling connection 'qemu+ssh://<user>@<host>/system': 0 details=Traceback (most recent call last): File "/usr/share/virt-manager/virtManager/engine.py", line 343, in _handle_tick_queue conn.tick_from_engine(**kwargs) File "/usr/share/virt-manager/virtManager/connection.py", line 1266, in tick_from_engine raise e # pylint: disable=raising-bad-type KeyError: 0 the exact location of the bug is in the _poll command: File "/usr/share/virt-manager/virtManager/connection.py", line 1093, in _poll "refreshing xml for new %s" % newlist[0].class_name(),
Forgotten to mention the libvirtd package version on the server: libvirt-bin Version: 0.9.12.3-1+deb7u1
*** This bug has been marked as a duplicate of bug 1219443 ***