This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 122714 - %scriptlets fail when /usr/share is mounted read-only
%scriptlets fail when /usr/share is mounted read-only
Status: CLOSED DUPLICATE of bug 122713
Product: Fedora
Classification: Fedora
Component: jakarta-regexp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-07 08:18 EDT by Enrico Scholz
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2004-05-07 08:18:33 EDT
Description of problem:

| # rpm -Uvh jakarta-regexp-1.2-15.i386.rpm
|    1:jakarta-regexp         ########################################### [100%]
| rm: cannot remove `/usr/share/java/jakarta-regexp.jar': Read-only file system
| ln: `/usr/share/java/jakarta-regexp.jar': File exists
| error: %post(jakarta-regexp-1.2-15) scriptlet failed, exit status 1
|
| # rpm -q jakarta-regexp
| jakarta-regexp-1.2-14
| jakarta-regexp-1.2-15
|  
| # rpm --showrc | grep netsha
| -14: _netsharedpath     ...:/usr/share:...
| 
| # cat /proc/mounts | grep /usr/share
| morden:/usr/share /usr/share nfs ro,...

See discussion at bug #51193 also.


Version-Release number of selected component (if applicable):

jakarta-regexp-1.2-15
Comment 1 Gary Benson 2004-05-07 12:47:12 EDT

*** This bug has been marked as a duplicate of 122713 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.