Bug 122717 - %scriptlets fail when /usr/share is mounted read-only
Summary: %scriptlets fail when /usr/share is mounted read-only
Keywords:
Status: CLOSED DUPLICATE of bug 122713
Alias: None
Product: Fedora
Classification: Fedora
Component: bcel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-07 12:45 UTC by Enrico Scholz
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:06 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Enrico Scholz 2004-05-07 12:45:49 UTC
Description of problem:

| # rpm -Uvh bcel-5.0-13.i386.rpm ...
| Preparing...                ########################################### [100%]
|    1:bcel                   ########################################### [ 50%]
| rm: cannot remove `/usr/share/java/bcel.jar': Read-only file system
| ln: `/usr/share/java/bcel.jar': File exists
| error: %post(bcel-5.0-13) scriptlet failed, exit status 1
| 
| # rpm -q bcel
| bcel-5.0-12
| bcel-5.0-13
| 
| # rpm --showrc | grep netsha
| -14: _netsharedpath     ...:/usr/share:...
| 
| # cat /proc/mounts | grep /usr/share
| morden:/usr/share /usr/share nfs ro,...

See discussion at bug #51193 also.


Version-Release number of selected component (if applicable):

bcel-5.0-13.i386

Comment 1 Gary Benson 2004-05-07 16:47:22 UTC

*** This bug has been marked as a duplicate of 122713 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:03:06 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.