Bug 1227194 - use "p" as delimiter for NVMe devices
Summary: use "p" as delimiter for NVMe devices
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grub
Version: 6.7
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: David Kaspar [Dee'Kej]
QA Contact: Release Test Team
Petr Bokoc
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1356047
TreeView+ depends on / blocked
 
Reported: 2015-06-02 06:28 UTC by Vaughan Cao
Modified: 2018-04-27 10:41 UTC (History)
3 users (show)

(edit)
*GRUB* does not support NVMe devices

Non-volatile memory NVM Express (NVMe) devices are not supported by the *GRUB* boot loader in Red Hat Enterprise Linux 6, and therefore the boot loader can't be installed on these devices.

To work around the problem, you can:

   * Use another storage device to install the boot loader
   * Upgrade to RHEL 7, which uses *GRUB2* as the default boot loader and supports installation to NVMe devices
Clone Of:
(edit)
Last Closed: 2017-12-06 12:04:22 UTC


Attachments (Terms of Use)
use "p" as delimiter for NVMe devices (804 bytes, patch)
2015-06-02 06:28 UTC, Vaughan Cao
no flags Details | Diff

Description Vaughan Cao 2015-06-02 06:28:59 UTC
Created attachment 1033604 [details]
use "p" as delimiter for NVMe devices

Description of problem:
Install grub on a partitioned nvme device failed with "No such partition" reported.
It's because grub install determines the NVMe device partition as /dev/nvme0n11 instead of /dev/nvme0n1p1, since it doesn't use "p" as the delimiter.

Version-Release number of selected component (if applicable):
grub-0.97-94

How reproducible:
Always

Steps to Reproduce:

Install grub on a partitioned nvme device failed.
# grub --device-map=/opt/oracle.cellos/tmpl/usbMap_nvme --verbose
Attempt to open drive 0x80 (/dev/nvme0n1)
Attempt to open drive 0x81 (/dev/nvme1n1)

grub> root (hd0,0)
root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
grub> setup (hd0)
setup (hd0)
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/grub/stage1" exists... yes
 Checking if "/grub/stage2" exists... yes
 Checking if "/grub/e2fs_stage1_5" exists... yes
 Running "embed /grub/e2fs_stage1_5 (hd0)"... failed (this is not fatal)
 Running "embed /grub/e2fs_stage1_5 (hd0,0)"... failed (this is not fatal)
 Running "install /grub/stage1 (hd0) /grub/stage2 p /grub/grub.conf "...
failed
 Error 22t: No such partition


Actual results:
grub install failed

Expected results:
succeed

Additional info:
I made a patch to fix it attached.

Comment 3 Pavel Holica 2016-10-21 12:53:38 UTC
Hello,
can you please try if grub-install works instead of running grub shell? If not, then we can try to fix grub-install script. If it works, please use grub-install, instead of the grub shell.

Comment 4 David Kaspar [Dee'Kej] 2016-11-09 17:03:24 UTC
Still no reply from the reporter, moving this to RHEL-6.10.

Comment 5 Jeff Byers 2017-11-28 16:02:02 UTC
I ran into the same problem, and 'grub-install' did not work for me either.
I had to make a private version of the package using the patch the reporter provided, which then worked.

Comment 6 Jan Kurik 2017-12-06 12:04:22 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.