Bug 122723 - Adding New File Type Doesn't Work
Summary: Adding New File Type Doesn't Work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-07 13:19 UTC by Aric
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 13:02:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aric 2004-05-07 13:19:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040504

Description of problem:
I have files with a .vhd extension. I want to call these VHDL files
and load a specific editor when I click on them.  When I add them with
gnome-file-types-properities program, nautilus still shows them as
plain text instead of a VHDL file.

Version-Release number of selected component (if applicable):
nautilus-2.6.0-4

How reproducible:
Always

Steps to Reproduce:
1. Run gnome-file-types-properties
2. Click on "Add File Type..."
3. Put whatever description you want. I used "VHDL File"
4. I used a MIME type of text/x-vhdl
5. Category is Documents/Plain Text
6. Filename extensions are vhd and vhdl.
7. You can keep the action, because I'm just interested in nautilus
showing the file as a VHDL file instead of plain text at this point.
8. Click OK.
9. Open a nautilus window showing a *.vhd file.  It is still shown as
Plain text.
    

Actual Results:  File is shown as "Plain text document"

Expected Results:  File should be shown as "VHDL File"

Additional info:

Comment 1 Alexander Larsson 2004-09-06 13:02:16 UTC
This should work in gnome 2.8 which is in rawhide.



Note You need to log in before you can comment on or make changes to this bug.