Bug 12273 - --onpart problem with kickstart
--onpart problem with kickstart
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-14 12:06 EDT by Juergen Weiss
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 17:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Weiss 2000-06-14 12:06:30 EDT
Using the following entries in the kickstart file

part /     --onpart sda5
part /boot --onpart sda1
part swap  --onpart sda6

the following message occured during installation

Exception Occured

 File "/usr/lib/anaconda/todo.py",
line 395, in addMount
    self.mounts[location] = (device, 
fsystem, reformat)
AttributeError: mounts
Comment 1 Michael Fulbright 2000-06-15 11:31:56 EDT
--onpart is know to have issues in 6.2.

I will investigate your particular case.
Comment 2 Michael Fulbright 2000-06-22 15:27:21 EDT
Did you have a clearpart directive in your ks file?

It won't generally work to have clearpart specified and try to use --onpart on
a logical partition, since if any logical partitions preceeding the logical
partition are removed then the numbering is all screwed up.
Comment 3 Michael Fulbright 2000-08-17 17:17:27 EDT
Please reopen this bug if you continue to have issues.

Note You need to log in before you can comment on or make changes to this bug.