Bug 1227371 - Session key changes to non-integer value which doesn't allow login
Summary: Session key changes to non-integer value which doesn't allow login
Keywords:
Status: CLOSED DUPLICATE of bug 1221117
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 7.0 (Kilo)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 7.0 (Kilo)
Assignee: Matthias Runge
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-02 14:00 UTC by wdaniel
Modified: 2015-09-07 05:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-03 06:14:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
sosreport from controller (7.40 MB, application/x-xz)
2015-06-02 14:00 UTC, wdaniel
no flags Details

Description wdaniel 2015-06-02 14:00:12 UTC
Created attachment 1033803 [details]
sosreport from controller

Description of problem:

After using Horizon for some time (a couple hours) and using it for basic administrative tasks (creating/deleting networks), we were presented with the login screen. Successful login attempts seemed to continually lead to the "Something went wrong" page. Looking at the horizon log it appears that somehow the session key stored in the browser's cookie had changed from a valid integer to a non-valid value:

   File "/usr/lib/python2.7/site-packages/django/db/models/fields/__init__.py", line 969, in to_python
     params={'value': value},
 ValidationError: [u"'008a010c2d134926a88a0d0516719eb3' value must be an integer."]

Once we cleared the cache/cookie for the site we were able to successfully log in again.s

Version-Release number of selected component (if applicable):

python-django-horizon-2015.1.0-6.el7ost.noarch


How reproducible:

Somewhat

Steps to Reproduce:
1. Deploy Packstack install
2. Use horizon for standard tasks
3. Wait to be prompted to login again

Actual results:

Successful login attempts result in an Internal Server Error

Expected results:

Successful login redirects to main page

Additional info:

We were able to successfully log in as the same user in a different browser while we were "locked out" of Horizon in the original browser. Also, we were not able to verify whether this was the result of some operation (we had been deleting and recreating tenant networks) or simply a matter of time. This behavior was noticed on 2 different packstack deployments using the same rpm versions.

Comment 3 wdaniel 2015-06-02 17:23:12 UTC
After trying to reproduce this it was noticed that this seems to be the result of a timeout. If left alone for about 10-20 minutes you are returned to the login screen, followed by the error screen. Manually deleting the 'sessionid' and 'token' elements of the cookie manually seem to fix this issue.

Comment 4 Matthias Runge 2015-06-03 06:14:28 UTC

*** This bug has been marked as a duplicate of bug 1221117 ***


Note You need to log in before you can comment on or make changes to this bug.