Bug 122746 - curl missing large file support
curl missing large file support
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: curl (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-07 13:06 EDT by Karlos Smith
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: 7.12.0-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 16:46:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karlos Smith 2004-05-07 13:06:55 EDT
Description of problem:
curl does not have Large File Support.  curl cannot save/download
files over 2G.


Version-Release number of selected component (if applicable):
curl-7.10.6-4.1

How reproducible:
Always

Additional info:
Like wget, LFS will be difficult to implement in curl.  It is needed
though.
Comment 1 Karlos Smith 2004-05-07 13:08:46 EDT
I selected i386 from the list, but don't see it in the bug report. 
LFS is only an issue on 32bit systems.
Comment 2 Eido Inoue 2004-05-10 11:43:14 EDT
this is not something that can be solved by a simple option to
configure, unfortunately.

(while this is a valid bug, its useful to point out that if you're
receiving/sending a file greater than 2 gigs, you probably shouldn't
be using http/https/ftp)
Comment 3 Karlos Smith 2004-05-10 18:03:19 EDT
I was only getting 22 bytes/sec downloading the Fedora Core 2 test3
DVD .iso off of bittorrent  :(

So, no, curl wasn't my first choice...

I even tried curl in 2G chunks, but the ftp server was broken and
would allow me to continue a file past the 2G mark.  So, I backed up a
few bytes continued just before the 2G mark and let it download the
next 2G.  Finally had to settle for the slow torrent feed for the last
100M or so.

Just very frustrating all in all.
Comment 4 Karlos Smith 2004-05-10 18:05:33 EDT
er...  That should say "would _not_ allow me to continue past the 2G
mark."
Comment 5 Eido Inoue 2004-05-17 11:08:40 EDT
7.11.x apparently does support large files-- will upgrade to that for
next update
Comment 6 Don Buchholz 2004-05-27 21:11:52 EDT
Just want to say "me too".  Been trying to download Fedora Core 2 DVD
ISO image ... curl is broke, wget is broke ... trying classic FTP now.
I will definately appreciate the next update.

Note You need to log in before you can comment on or make changes to this bug.