Bug 122748 - Cannot rotate images with upper case extensions
Cannot rotate images with upper case extensions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marco Pesenti Gritti
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-07 13:10 EDT by Harry Waye
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 12:38:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harry Waye 2004-05-07 13:10:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040505

Description of problem:
I cannot seem to rotate images with uppercase extentions.  i.e. can
rotate 'image.jpg' but not 'image.JPG'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open gthumb
2. try to rotate 'image.JPG'
3. image.JPG still same orientation
    

Actual Results:  Image remains the same.

Expected Results:  The desired transformation is applied to the image.

Additional info:

Perhaps a tolower is needed?  Or is this the correct behaviour?  I
would not have thought so.
Comment 1 Per Bjornsson 2004-05-13 04:20:57 EDT
Yes, it seems that gthumb is simply not identifying the pictures as
jpeg images. Workaround: In Edit>Preferences, on the "Browser" tab,
check the checkbox "Determine image type from content (slower)"; after
doing this rotating images works (at least with jpeg files from my
digital camera; haven't tried any other file types).

Of course it's not correct behavior; pleas don't ask for an
"unbreak-me" option, this should just be fixed. :) It's actually
really annoying since the default for importing images from digital
cameras is often to use uppercase filenames since they typically use
FAT filesystems.
Comment 2 Marco Pesenti Gritti 2004-11-04 12:38:33 EST
This is fixed in RAWHIDE soon to become Fedora Core 3.

Note You need to log in before you can comment on or make changes to this bug.