Bug 122752 - Alt-Tab doesn't terminate
Alt-Tab doesn't terminate
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
: 123792 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-07 13:45 EDT by Andy Ross
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-16 20:16:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Ross 2004-05-07 13:45:46 EDT
With FC2 devel as of Friday:

Do an Alt-Tab: the selector window pops up normally, and I can bounce
between selections as I always have, with highlight rectangles showing
the selcted window.

Release the keys: nothing happens.  The selector window and highlight
stay on the screen, and I have to click the mouse to get the desktop
back into "normal" mode.  My selected window doesn't get the focus,
either.
Comment 1 Greg Kimberly 2004-05-11 22:36:38 EDT
With FC2 test3 I get the same behavior. The selector window pops up,
alt-tab cycles between selections with highlight rects appearing, but
there doesn't seem to be any way to make the selector change the top
window. It's as if it can't "hear" the keyup event for the alt key.
(On my machine the selector window keeps responding to tab presses
even after you release the alt key.) 
Comment 2 Douglas Furlong 2004-05-13 11:46:31 EDT
On my system I am having no problems what so ever with alt + tabing
between applications.

I am running an yum update now, will let you know if any thing changes.
Comment 3 Greg Kimberly 2004-05-19 01:21:56 EDT
On Fedora Core 2 final I still get this behavior. 
Comment 4 Greg Kimberly 2004-05-19 01:29:00 EDT
What's the proper route to changing this bug's scope to Fedora Core 2
final instead of test 3, btw? 
Comment 5 Havoc Pennington 2004-05-20 15:08:38 EDT
Changing version. 
Comment 6 Al Cousson 2004-05-20 15:35:19 EDT
*** Bug 123792 has been marked as a duplicate of this bug. ***
Comment 7 Elijah Newren 2004-05-21 15:45:29 EDT
I can duplicate as well--but only when using the right alt key instead
of the left one.
Comment 8 Elijah Newren 2004-05-21 15:58:07 EDT
This also affects Ctrl-Alt-Arrow, and again, it is only a problem when
the right alt key is used instead of the left.
Comment 9 Greg Kimberly 2004-05-21 17:59:01 EDT
Interesting! Just tried that on my machine and sure enough
left-tab-alt does terminate. Does this mean there's something odd
about the keymap perhaps?


Comment 10 Richard Plana 2004-05-21 18:59:10 EDT
Happens to me, too, but only with with Windows keys. Seems
reproducible on the three different platforms I have. Some details:

1. When using the Keyboard Shortcuts capplet to configure shortcut
keys, depressing the <WIN> key stop the key combination process.

2. Whereas in my older system, the symbold <Mod4> would be used for
the WIN key, now it seems to use <Super_L>

3. Manually gconfiguring
/apps/metacity/global_keybindings/cycle_windows to "<Mod4>Tab" would
allow me to WIN-Tab cycle through the various windows, but it seems
the key gets "stuck". Releasing they keys would leave metacity in
windows cycling mode.
Comment 11 Elijah Newren 2004-05-21 23:13:11 EDT
I filed upstream with the extra information I've found at
  http://bugzilla.gnome.org/show_bug.cgi?id=142947
Comment 12 Elijah Newren 2004-05-24 11:39:45 EDT
As noted upstream, this isn't a Metacity bug.  A simple "xmodmap |
grep mod1" on FC2 shows
  mod1        Alt_L (0x40),  Alt_L (0x7d),  Meta_L (0x9c)
Alt_R is clearly missing from the list, but a simple 

  xmodmap -e "add mod1 = Alt_R"

will fix that and get rid of this "remaining-popup" problem, at least
until the Xserver restarts (i.e. until you log out).  This should be
reassigned against the X packages.  [Also, note that this is specific
to FC2, as Alt_R does appear in the list for me in FC1]
Comment 13 Andy Ross 2004-05-28 11:10:50 EDT
I came by to check on the status of this bug, as it has been silent
and unfixed for the past week or so.  It turned out to have been
assigned to "xfce-utils", which has to have been a mistake.  I assume
xorg-x11 is the appropriate component?
Comment 14 Elijah Newren 2004-05-28 16:12:30 EDT
Yeah, xorg-x11 seems right to me.  Since I'm not privileged, could
someone also change the summary to "Alt_R doesn't appear in mod1 list
from xmodmap, causing various Metacity issues" or something similar?
Comment 15 Richard Plana 2004-05-28 16:46:50 EDT
I just wanted to add that adding the entries via xmodmap solved the
problem for Alt_R and Super_R but not for Super_L (which actually
appears in the xmodmap default to begin with).
Comment 16 Richard Plana 2004-05-28 17:38:46 EDT
Temporary fix for Super_L problem:

$ xmodmap -e "clear mod4"
$ xmodmap -e "add mod4 = Super_L"

Doing an xmodmap after this will show that two values have been
assigned to Super_L:

mod4        Super_L (0x73),  Super_L (0x7f)
Comment 17 Richard Plana 2004-05-28 17:53:28 EDT
Note: This may also be an issue of control-center's (specifically
gnome-keyboard-properties). I tried creating an $HOME/.xmodmaprc file
and was informed that gnome-keyboard-properties handles it now.
However, after trying the various combinations in
gnome-keyboard-properties, none of them fixed the mapping for either
Alt_R, Super_R or Super_L.
Comment 18 Kristian Høgsberg 2004-07-26 15:54:29 EDT
The X.org 6.7 release included an update (XFree86 4.4 seems to have it
too) to the xkb files which changes the way Alt_R is setup.  I've
filed a bug in the X.org bugzilla:

  http://freedesktop.org/bugzilla/show_bug.cgi?id=926
Comment 19 Elijah Newren 2004-09-11 15:06:52 EDT
In that freedesktop.org bug, they claim they won't revert the
Xorg/XFree86 change and that Metacity has to be modified.  Could this
bug be reassigned back to Metacity?

Of course, Havoc might mark this as upstream; the same issue is now
being covered at http://bugzilla.gnome.org/show_bug.cgi?id=151554 .
Comment 20 Elijah Newren 2004-10-16 10:53:05 EDT
Soeren submitted a patch against metacity upstream at the URL in my
last comment which fixes this issue.
Comment 21 Havoc Pennington 2004-10-16 20:16:01 EDT
Soeren put the fix in our package and I rebuilt it, should be in
rawhide soon.

Note You need to log in before you can comment on or make changes to this bug.