Bug 1227569 - The Status TUI display the wrong Networking status when the cable of the target link has been unpluged.
Summary: The Status TUI display the wrong Networking status when the cable of the targ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.3
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Fabian Deutsch
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-03 03:27 UTC by Chaofeng Wu
Modified: 2016-03-09 14:28 UTC (History)
10 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:28:41 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
Network status TUI (1.98 MB, image/jpeg)
2015-06-03 03:27 UTC, Chaofeng Wu
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 41872 master MERGED tui: More detailed info about connection state Never

Description Chaofeng Wu 2015-06-03 03:27:12 UTC
Created attachment 1034120 [details]
Network status TUI

Description of problem:
The status TUI display wrong Networking status after Network configured to the "DHCP" mode when the cable of the target link has been unpluged.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.6-20150512.0.el6ev.noarch
rhevh-6.6-20150512.0.el6ev.iso
ovirt-node-3.2.2-3.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clean install rhevh-6.6-20150512.0.el6ev.iso
2. Unplug the cable of the target link "eth0" on the test machine.
3. Login rhevh and configure network as IPv4 DHCP mode on the link "eth0".
4. Go to the Status TUI and check the Networking status of the link "eth0".

Actual results:
The Networking status of link "eth0" display "Connected" on the Status TUI.

Expected results:
The Networking status of link "eth0" should display "Not connected" on the Status TUI.

Additional info:
The network service restart action should be failed with IPv4 DHCP configuration after unpluged the cable of the link "eth0", but the TUI display "All changes were applied successfully" during the network configuration. It would be better to check exit status of network service restart action and to display the exceptions to tell users the configuration already failed.

Comment 1 Fabian Deutsch 2015-06-03 08:26:14 UTC
Is this also the case on RHEV-H 7?

Comment 2 Fabian Deutsch 2015-06-03 09:03:14 UTC
It is also the case on el7.

Comment 4 yileye 2015-12-09 10:44:50 UTC
I can reproduce this bug in (rhev-hypervisor6-6.6-20150512.0.el6ev.noarch/ovirt-node-tools-3.2.3-20.el7.noarch).

Test version:
ovirt-node-3.6.0-0.23.20151201git5eed7af.el7ev.noarch 
RHEV-H 7.2-20151201.2.el7ev

Test Steps:
1. Clean install RHEV-H 7.2-20151201.2.el7ev
2. Unplug the cable of the target  "enp0s25" on the test machine.
3. Login rhevh and configure network as IPv4 DHCP mode on the link "enp0s25".
4. Go to the Status TUI and check the Networking status of the link "enp0s25".

Test results:
The Networking status of link "enp0s25" should display "Not connected" on the Status TUI.

So the bug is fixed, change bug status to VERIFIED.

Comment 7 errata-xmlrpc 2016-03-09 14:28:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.