Bug 1227590 - bug-857330/xml.t fails spuriously
Summary: bug-857330/xml.t fails spuriously
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1232602
TreeView+ depends on / blocked
 
Reported: 2015-06-03 05:14 UTC by Atin Mukherjee
Modified: 2016-06-16 13:07 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1232602 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:07:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2015-06-03 05:14:34 UTC
Description of problem:

bug-857330/xml.t fails spuriously in test case 14

Version-Release number of selected component (if applicable):
Mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-06-03 05:16:48 UTC
REVIEW: http://review.gluster.org/11054 (tests: fix spurious failure in bug-857330/xml.t) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Anand Avati 2015-06-03 06:34:47 UTC
REVIEW: http://review.gluster.org/11055 (tests: rebalance completed should only check the status for completed) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Anand Avati 2015-06-03 07:31:33 UTC
REVIEW: http://review.gluster.org/11054 (tests: fix spurious failure in bug-857330/xml.t) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Anand Avati 2015-06-03 12:32:10 UTC
REVIEW: http://review.gluster.org/11054 (tests: fix spurious failure in bug-857330/xml.t) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 5 Anand Avati 2015-06-08 04:55:23 UTC
REVIEW: http://review.gluster.org/11054 (tests: fix spurious failure in bug-857330/xml.t) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 6 Anand Avati 2015-06-08 04:55:38 UTC
REVIEW: http://review.gluster.org/11055 (tests: rebalance completed should only check the status for completed) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 7 Anand Avati 2015-06-09 05:11:12 UTC
REVIEW: http://review.gluster.org/11054 (tests: fix spurious failure in bug-857330/xml.t) posted (#5) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 8 Anand Avati 2015-06-09 17:28:31 UTC
REVIEW: http://review.gluster.org/11054 (tests: fix spurious failure in bug-857330/xml.t) posted (#6) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 9 Anand Avati 2015-06-15 04:41:22 UTC
REVIEW: http://review.gluster.org/11054 (tests: fix spurious failure in bug-857330/xml.t) posted (#7) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 10 Anand Avati 2015-06-16 10:01:08 UTC
COMMIT: http://review.gluster.org/11054 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit f65490c5d87c4282717b7f28cfcd1fe9380c6154
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Wed Jun 3 10:40:36 2015 +0530

    tests: fix spurious failure in bug-857330/xml.t
    
    get-task-status () used to always return 0 *until and unless* the CLI command
    itself fails which is unlikely. However if the CLI command fails due to some
    reason EXPECT_WITHIN will abort.
    
    Change-Id: Ibe54dcdccc26b3ee003677fc3516cfed98b5c06f
    BUG: 1227590
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/11054
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 11 Anand Avati 2015-06-17 08:47:02 UTC
COMMIT: http://review.gluster.org/11055 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 1950f30ee77df938a76159f07fe8f8ca3ef14cf8
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Wed Jun 3 12:03:05 2015 +0530

    tests: rebalance completed should only check the status for completed
    
    Change-Id: I1abc91cefaf16d1c8351f35e951c26078ef90544
    BUG: 1227590
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/11055
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 12 Raghavendra Talur 2016-03-08 20:12:52 UTC
"tests" component is for tests framework only.
File a bug under test component if you find a bug in 
1. any of the *.rc files under tests/ 
2. run-tests.sh


For everything else, the bug should be filed on
1. component which is being tested by .t file if the .t file requires fix.
2. component which is causing a valid .t file to fail in regression.

I have used my best judgement here to move the bug to right component.
In case of ambiguity, I have placed the blame on the .t file component.

Please consider test bugs under the same backlog list that tracks other bugs in your component.

Comment 13 Niels de Vos 2016-06-16 13:07:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.