Bug 1227611 - Fix deadlock in timer-wheel del_timer() API
Summary: Fix deadlock in timer-wheel del_timer() API
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Venky Shankar
QA Contact:
URL:
Whiteboard:
Depends On: 1227449 1231026
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-03 06:37 UTC by Venky Shankar
Modified: 2015-06-20 09:49 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1227449
Environment:
Last Closed: 2015-06-20 09:49:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Venky Shankar 2015-06-03 06:37:42 UTC
+++ This bug was initially created as a clone of Bug #1227449 +++

Description of problem:
Deadlock in timer-wheel (contrib/timer-wheel) del_timer() API.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
always

--- Additional comment from Anand Avati on 2015-06-02 12:57:05 EDT ---

REVIEW: http://review.gluster.org/11050 (contrib/timer-wheel: fix deadlock in del_timer()) posted (#1) for review on master by Venky Shankar (vshankar@redhat.com)

--- Additional comment from Anand Avati on 2015-06-02 23:24:35 EDT ---

COMMIT: http://review.gluster.org/11050 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 9a314fa22667bf5afe56e63e73f4b0f50cd291f6
Author: Venky Shankar <vshankar@redhat.com>
Date:   Tue Jun 2 21:49:13 2015 +0530

    contrib/timer-wheel: fix deadlock in del_timer()
    
    commit eaf3bfa added mod_timers() and successfully screwed up
    del_timer() by incorrectly wrapping it within double lock
    blocks.
    
    del_timer() was included before the above commit for the sake of
    timer API completion, thankfully noone used it till now.
    
    Change-Id: I07a454a216cf09dbb84777a23630e74a1e7f2830
    BUG: 1227449
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/11050
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 1 Anand Avati 2015-06-03 06:43:10 UTC
REVIEW: http://review.gluster.org/11056 (contrib/timer-wheel: fix deadlock in del_timer()) posted (#1) for review on release-3.7 by Venky Shankar (vshankar@redhat.com)

Comment 2 Anand Avati 2015-06-04 10:41:13 UTC
COMMIT: http://review.gluster.org/11056 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit b27ab7737f76d2a65e790afe3872f16dc3e7e078
Author: Venky Shankar <vshankar@redhat.com>
Date:   Tue Jun 2 21:49:13 2015 +0530

    contrib/timer-wheel: fix deadlock in del_timer()
    
        Backport of http://review.gluster.org/11050
    
    commit eaf3bfa added mod_timers() and successfully screwed up
    del_timer() by incorrectly wrapping it within double lock
    blocks.
    
    del_timer() was included before the above commit for the sake of
    timer API completion, thankfully noone used it till now.
    
    Change-Id: I07a454a216cf09dbb84777a23630e74a1e7f2830
    BUG: 1227611
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/11056
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 3 Niels de Vos 2015-06-20 09:49:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.