Bug 1227646 - Glusterd fails to start after volume restore, tier attach and node reboot
Summary: Glusterd fails to start after volume restore, tier attach and node reboot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On: 1224175
Blocks: 1223636 1228592
TreeView+ depends on / blocked
 
Reported: 2015-06-03 08:32 UTC by Avra Sengupta
Modified: 2016-06-16 13:07 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1224175
: 1228592 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:07:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-03 10:01:17 UTC
REVIEW: http://review.gluster.org/11060 (snapshot: Fix finding brick mount path logic) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-06-05 09:22:34 UTC
COMMIT: http://review.gluster.org/11060 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit bf3a6dcdf3c8a8a64e7c864b56c4d9be60fca8e6
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Wed Jun 3 15:18:08 2015 +0530

    snapshot: Fix finding brick mount path logic
    
    Previously while finding brick mount paths
    of snap volume's bricks, we were taking brick order
    into consideration. This logic fails when a brick is
    removed or a tier is added.
    
    Hence modifying the logic to look for the first
    occurence of the word "brick" in the brick path.
    From there we iterate till we find a '/'. The string
    till the first '/' after we encounter the word brick
    is the brick mount path.
    
    Change-Id: Ic85983c4e975e701cdfd4e13f8e276ac391a3e49
    BUG: 1227646
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/11060
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 14:42:12 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Niels de Vos 2016-06-16 13:07:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.