Bug 12277 - subpackages with different arch
subpackages with different arch
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-14 12:51 EDT by gerald
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-14 12:51:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gerald 2000-06-14 12:51:06 EDT
I tried to build an "i386" package which contains subpackages which are
noarch.

Hence I added "BuilArch: noarch" to the "%package" section of each 
corresponding subpackage. This results in all packages beeing "noarch".
So I tried to say "BuilArch: i386" for the main package and all
subpackages beeing i386. This resulted in all packages beeing "i386".

Summary: It looks like rpm takes the first "BuildArch" it finds and
uses it for ALL (sub)packages.

BTW: Why do I have to specify "Group" for each package?
Comment 1 Jeff Johnson 2000-06-14 13:12:05 EDT
By design, rpm permits only one architecture per spec file parse. That
means that you are forbidden to have noarch sub-packages of a arch specific
package.

Group tag is similarly (i.e. by design) required.
Comment 2 gerald 2000-06-14 13:25:24 EDT
Why does rpm permit only one architecture per spec file parse? this makes 
absolutely no sense to me!

I have a package which has ~100MB. About 60MB thereof is additional 
documentation. I want to split off the additional documentation since
it eats up space and is by no means neccesary to run the software.
Since the doc is "noarch" why should'nt I be able to tell rpm that it is!?
Again this "feature" makes NO sense to me. Please change it.

Note You need to log in before you can comment on or make changes to this bug.