Bug 1227873 - Don't overwrite all Tuskar parameters when deploying
Summary: Don't overwrite all Tuskar parameters when deploying
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Lennart Regebro
QA Contact: Ola Pavlenko
URL:
Whiteboard:
: 1232837 1234146 (view as bug list)
Depends On: 1193922 1236687
Blocks: 1232838
TreeView+ depends on / blocked
 
Reported: 2015-06-03 17:02 UTC by Lennart Regebro
Modified: 2015-08-05 13:52 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-image-elements-0.9.6-2.el7ost python-rdomanager-oscplugin-0.0.8-8.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:52:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 236804 None None None Never
Gerrithub.io 237311 None None None Never
OpenStack gerrit 193868 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Lennart Regebro 2015-06-03 17:02:39 UTC
Description of problem:

The RDO manager plugin will overwrite all the Tuskar parameters when deploying the overcloud. That makes it impossible to change the configuration before deploying, making it of little using in a real life production environment.

Instead setting tuskar parameters should be done in a separate command by loading it from a configuration file, so it can be modified before deploying.

See also https://bugzilla.redhat.com/show_bug.cgi?id=1227870

Comment 3 Lennart Regebro 2015-06-22 13:41:43 UTC
Patches for review:

https://review.openstack.org/#/c/193868/
https://review.gerrithub.io/#/c/236804/

Comment 4 Lennart Regebro 2015-06-23 09:12:16 UTC
Last patch for review, to do the same for scaling parameters:

https://review.gerrithub.io/#/c/237311/

Comment 5 chris alfonso 2015-06-23 17:52:36 UTC
*** Bug 1234146 has been marked as a duplicate of this bug. ***

Comment 6 James Slagle 2015-06-23 18:39:36 UTC
i've applied the tripleo-image-elements patch downstream:
https://code.engineering.redhat.com/gerrit/#/c/51401/
it'll be built into openstack-tripleo-image-elements-0.9.6-2.el7ost

Comment 8 Udi 2015-06-29 18:07:26 UTC
Can't test due to bug: https://bugzilla.redhat.com/show_bug.cgi?id=1236687

Comment 9 Mike Burns 2015-06-29 18:15:35 UTC
It's not failed, it's blocked.  Moving back to ON_QA

Comment 10 Lennart Regebro 2015-06-30 14:53:16 UTC
*** Bug 1232837 has been marked as a duplicate of this bug. ***

Comment 11 Udi 2015-07-05 12:57:26 UTC
Verified in python-rdomanager-oscplugin-0.0.8-18.el7ost.noarch

Comment 13 errata-xmlrpc 2015-08-05 13:52:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.