Bug 1227936 - instack-virt-setup output is not logged
Summary: instack-virt-setup output is not logged
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: Director
Hardware: Unspecified
OS: Unspecified
low
high
Target Milestone: ga
: Director
Assignee: Ben Nemec
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-03 21:14 UTC by Ben Nemec
Modified: 2015-08-05 13:52 UTC (History)
6 users (show)

Fixed In Version: instack-undercloud-2.1.2-6.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:52:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 235126 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ben Nemec 2015-06-03 21:14:28 UTC
Description of problem: If instack-virt-setup fails, the output is only available in the shell scrollback, which can be awkward for post-mortem debugging.


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. Run instack-virt-setup
2.
3.

Actual results: Output not logged


Expected results: A log file


Additional info: Fix proposed: https://review.gerrithub.io/#/c/235126/

Comment 5 Mike Burns 2015-06-12 13:02:49 UTC
Midstream is not yet merged, moving to ON_DEV

Comment 7 Omri Hochman 2015-07-07 21:51:51 UTC
verified using instack-undercloud-2.1.2-11.el7ost.noarch : found the file under /home/stack/.instack/virt-setup.log

Comment 9 errata-xmlrpc 2015-08-05 13:52:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.