Bug 1227940 - deployment_mode in undercloud.conf does nothing
Summary: deployment_mode in undercloud.conf does nothing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: Ben Nemec
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-03 21:34 UTC by Ben Nemec
Modified: 2015-08-05 13:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Deprecated Functionality
Doc Text:
The deployment_mode configuration for the Undercloud that could be set in instack.answers in tech preview has been removed. deployment_mode allowed choosing a "scale" mode that deployed individual roles onto specific nodes. This functionality has been replaced with the node tagging features part of the Automated Health Check (AHC) tools.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:52:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ben Nemec 2015-06-03 21:34:42 UTC
Description of problem: There is a configuration option for instack-undercloud that does nothing, and is potentially confusing to users.


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Install instack-undercloud
2. Look at sample config file
3.

Actual results: deployment_mode setting


Expected results: No deployment_mode setting


Additional info:

Comment 3 Ben Nemec 2015-06-03 21:46:59 UTC
https://review.gerrithub.io/#/c/235135/

Comment 6 Mike Burns 2015-06-12 13:03:41 UTC
Upstream not yet merged, moving to ON_DEV

Comment 8 Alexander Chuzhoy 2015-06-19 16:11:57 UTC
Verified:

Environment:
instack-undercloud-2.1.2-1.el7ost.noarch


The command 'grep deployment_mode /home/stack/undercloud.conf' returns nothing now.

Comment 10 errata-xmlrpc 2015-08-05 13:52:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.